Author Topic: CMD Closing immediately after opening| Help please!  (Read 571 times)

0 Members and 1 Guest are viewing this topic.

Offline Kuroix12

  • Newbie
  • *
  • Join Date: Nov 2017
  • Posts: 1
  • Karma: 0
    • View Profile
CMD Closing immediately after opening| Help please!
« on: November 21, 2017, 06:54:24 PM »
[Some background]
I was dual booting Windows 10 and 7 until recently. After moving some games and documents over to my fresh Windows 7 install - I decided to format the W10 partition and allocate all the free space to my W7 using "Aomei" now up until this point I was able to use the cmd and it wouldn't close. However, after rebooting, I came to face an "assign volume letter" error. After running a Memory Diagnosis test and CHKDSK, it worked again and I was able to move past the boot screen and into the OS.

However, this time instead of just going straight to the desktop, it hanged(and continues to do so) on a black screen, then a cmd prompt pops up in the top right, it has some words on it but it flashes so suddenly I can't read it. It shrinks into a tiny prompt, minimizes itself, and then the desktop boots as normal. I figured "whatever, it works". However, recently I've been trying to use the cmd and it's crashing as soon as I open it. I can't even do a system restore because I forgot to create a restoration point after I finished installing all the proper drivers and haven't had the OS long enough for it to have been made by itself. I'm trying to fix this and could really use you guys' help!

[Things I've tried]
Running CMD as Administrator,
Running CMD /k,
Booting from my windows 7 repair disk and using the sfc /scannow /offbootdir=c:\ /offwindir=c:\windows command - it hangs up at "Beginning system scan" it never continues to, or shows the next line where it verifies files.
Checking the Environment Variables,
Running Iolo's "System Mechanic"
Using Tweakings' Windows All-in-one Repair[ it stops at repair 3/45 and gives me this: "Running Repair Under Current User Account
   Running Repair Under System Account
   Done (11/21/2017 6:40:01 PM)

   Done, but failed, at (11/21/2017 6:40:01 PM)
   Total Repair Time: 00:10:17

The current repair has failed to start 4 times.
Something is keeping the repair from running." - Note: I am running on clean boot atm, following the directions I've found from Tweaking.com and also booted into Safe Mode. I'm attaching the windows repair logs from this latest run if that helps at all.

I'm running Windows 7 Home Basic 64 bit

Thanks in advance to anyone who can help!
« Last Edit: November 21, 2017, 07:09:59 PM by Kuroix12 »

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 7089
  • Location: UK
  • Karma: 106
    • View Profile
Re: CMD Closing immediately after opening| Help please!
« Reply #1 on: November 22, 2017, 01:10:56 AM »
Those individual repair logs are all empty for me - probably because it only got as far as repair 3, but there should have been reports for the first two.

Can you go Start - type eventvwr and press enter.

When Even Viewer opens, ensure Event Viewer (Local) is highlighted in the left pane - if it isn't then just click on it.

When it has read the data, click on Error then on View All Instances of This Event in the lower right pane and look for date and time stamped errors for when you have booted up, but I think another clean install of Win 7 would be the way to go if the chkdsk didn't report any KBs in bad sectors.

Clicking on any of the errors will give a brief description in the pane below and for some, Googling those will usually give what people have found to fix them.

In the advanced boot options you could try Repair your computer and the start up repair to see what that reports and it's advocated to run that up to three times, but it's rare that it can fix anything.

There's also the Last Known Good Configuration option to try.