Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Shane

Pages: 1 ... 587 588 [589]
8821
v1.4.0 is out, make sure to update :-)

Tweaking.com - Windows Repair (All in One) v1.4.0
http://www.tweaking.com/content/page/windows_repair_all_in_one.html

v1.4.0
Removed the custom buttons from the program. It was causing the program to crash on some systems. Program is meant to repair, not look pretty, so ugly standard safe buttons it is :-)
Add new repair "Repair Windows Sidebar/Gadgets"
Changed the window size of the repair window, making it smaller and easier to fit on screen for smaller resolutions.
More code tweaks.

Shane

8822
Should be fixed now in v1.4.0 :-)

Shane

8823
User Submitted Tweaks & Guides / Re: Fix Gadget not working win7
« on: October 10, 2011, 03:09:37 PM »
Added to the program. Thanks again bud :-)

Tweaking.com - Windows Repair (All in One) v1.4.0
http://www.tweaking.com/content/page/windows_repair_all_in_one.html

v1.4.0
Removed the custom buttons from the program. It was causing the program to crash on some systems. Program is meant to repair, not look pretty, so ugly standard safe buttons it is :-)
Add new repair "Repair Windows Sidebar/Gadgets"
Changed the window size of the repair window, making it smaller and easier to fit on screen for smaller resolutions.
More code tweaks.

Shane

8824
Yeah, just checked and it is my custom buttons doing it for some odd reason.

Point of the program is to be able to run on a broken system. Thats why it isn't in .Net and why I don't use the Windows theme to make it look nicer. If those things are messed up on the system it wont run.

So I went with a custom button. I am going to remove it and just use the old ugly buttons. After all it is meant to repair, not look pretty :-)

I will have an update out later this week. :wink:

Shane

8825
I remember your system now. It kept running out of resources.

Yours will be a good test to see how the new version does and any fine tuning I need to do. I will be back on chat when your online :wink:

Shane

8826
User Submitted Tweaks & Guides / Re: Fix Gadget not working win7
« on: October 09, 2011, 11:33:09 AM »
Thanks for the repair guide :-)

I will get this added to the Windows repair tool as well later this week.

I would make some small changes. My Windows 7 has both a 64 & 32 bit of the sidebar on the system. There was a few gadgets that would only work with the 32 bit version and there was a reg trick to have a 64 bit version of windows run the 32 bit sidebar in order for them to work.

So here is the changes I would make.
I will add the 32 bit ones for a 64 bit system as well, on a 32 bit system the bat file would just move right past it.
http://technet.microsoft.com/en-us/library/cc749104%28WS.10%29.aspx


taskkill /im sidebar.exe /f
regsvr32 /s msxml3.dll
regsvr32 /s scrrun.dll
regsvr32 /s jscript.dll
regsvr32 /s atl.dll
Regsvr32 /s "%ProgramFiles(X86)%\Windows Sidebar\sbdrop.dll"
Regsvr32 /s "%ProgramFiles(X86)%\Windows Sidebar\wlsrvc.dll"
Regsvr32 /s "%ProgramFiles%\Windows Sidebar\sbdrop.dll"
Regsvr32 /s "%ProgramFiles%\Windows Sidebar\wlsrvc.dll"
reg delete "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones" /f
"%ProgramFiles%\Windows Sidebar\sidebar.exe"


So I just added these 2 lines
Regsvr32 /s "%ProgramFiles(X86)%\Windows Sidebar\sbdrop.dll"
Regsvr32 /s "%ProgramFiles(X86)%\Windows Sidebar\wlsrvc.dll"

and changed the last line from
"C:\Program Files\Windows Sidebar\sidebar.exe"
to
"%ProgramFiles%\Windows Sidebar\sidebar.exe"

Just for those People who don't have Windows on C: :wink:

Great fix, I didn't know this one, so this will be a nice addition to the repair program and very helpful for any readers that need it.

Thanks again!

Shane

8827
I havent seen the Windows 8 refresh yet, i should check it out.

Thanks for letting me know the program crashed. I wonder if it is the custom buttons I made doing it.

I will check first thing in the morning  :wink:

Shane

8828
Great! I will be waiting :-)

Shane

8829
Looks like Safe mode wont work.

I wanted users to avoid their scanners and such getting in the way. But when I did a test run in Vista safe mode, psexec.exe crashes.

So looks like the repair tool will need to be ran in Windows normally :wink:

Shane

8830
Lets find out :wink:

send me an email and we will get on chat and get you fixed up.

also did you try running the new version in safe mode?

psexec.exe is the key to getting things working right. I found that while on my test systems everything worked fine that on some other systems the trusted installer in Windows got in the way. This messed up the permissions of some of the reg keys and thus broke things.

Running the new version will run the reg permissions repair as the system account, thus the trusted installer is no longer in the way and the reg permissions get set correctly.

Had 3 people do this and every problem they had from the old version of the program was fixed, and since this was able to fix more reg keys now since it wasn't being blocked by the trusted installer it helped fix even more problems :-)

So we need to find out why the psexec.exe isn't working for you. Antivirus? Something else in the back ground?
So lets try Safe mode. If Windows safe mode does the trick I am going to put in the program that for the best results run this program in safe mode.  :cheesy:

Shane

8831
Here you go bud v1.3.0
http://www.tweaking.com/files/setups/Tweaking.com-WindowsRepair.exe

I just had 3 users who had problems after running my old version run this and they all are fixed :wink:

Shane

8832
Perfect timing :-)

I finally found what was causing the problems on some peoples systems and I have it fixed. Not only that but if you run the new version on your system it will fix the problems the old version caused  :wink:

V1.3.0 will be out in the next 30 min. I will post here and let you know.

Shane

8833
I have never used the iobit software so I don't know. But I wouldn't think that it would.  :wink:

Shane

8834
Windows Repair does a good job on a lot of systems.

But on some systems there might be something that is out of whack that can make things worse.

Always make sure to do a system restore backup before using the program.

If you need help after using the repair tool just ask me and I will be more than happy to help. The more people I help the better I can make the repair program.

As of v1.3.0 I was able to not only fix all the problems the old versions caused for people but I also made sure it wouldn't happen again.
The problem was with the reg & file permissions and the trusted installer messing things up. I had the users who had problems from my old version run this new version and it fixed everything right up  :cheesy:


Again if you have trouble just let me know! It is the only way I can make the program better & safer  :wink:

Shane

Pages: 1 ... 587 588 [589]