Tweaking.com Forums

Main Forum => Tweaking.com Programs & Site Help & Support => Topic started by: AndreTriAxis on October 08, 2015, 03:57:41 AM

Title: Registry Backup has stopped working
Post by: AndreTriAxis on October 08, 2015, 03:57:41 AM
The Registry Backup was working well on my W2k8 but suddenly I am receiving the 'Registry Backup has stopped working' windows error.
I tried to reinstall but the error persists.
The error details are:
Problem signature:
  Problem Event Name:   APPCRASH
  Application Name:   TweakingRegistryBackup.exe
  Application Version:   3.2.0.3
  Application Timestamp:   561407e6
  Fault Module Name:   OLEAUT32.dll
  Fault Module Version:   6.1.7601.18679
  Fault Module Timestamp:   54754919
  Exception Code:   c0000005
  Exception Offset:   00026b9f
  OS Version:   6.1.7601.2.1.0.274.10
  Locale ID:   1046
  Additional Information 1:   81e3
  Additional Information 2:   81e3d979e6b6c78899103bdd65561461
  Additional Information 3:   81e3
  Additional Information 4:   81e3d979e6b6c78899103bdd65561461

Regards,

Andre.
Title: Re: Registry Backup has stopped working
Post by: Shane on October 09, 2015, 12:41:35 AM
I just put out v3.3.0 today try it and let me know how it does for you.

Shane
Title: Re: Registry Backup has stopped working
Post by: falcon_four on October 09, 2015, 12:46:46 AM
Hi,

I'm getting a similar problem with 2012 r2 Std.

When trying to run Registry Backup v3.3.0 I get 2 immediate crashes:

Problem signature:
  Problem Event Name:   BEX
  Application Name:   TweakingRegistryBackup.exe
  Application Version:   3.3.0.0
  Application Timestamp:   5616dcb3
  Fault Module Name:   StackHash_9c08
  Fault Module Version:   0.0.0.0
  Fault Module Timestamp:   00000000
  Exception Offset:   PCH_4F_FROM_ntdll+0x0003CA2C
  Exception Code:   c0000005
  Exception Data:   00000008
  OS Version:   6.3.9600.2.0.0.272.7
  Locale ID:   2057
  Additional Information 1:   9c08
  Additional Information 2:   9c08bf844261db9fabf8f96c28895e86
  Additional Information 3:   f11e
  Additional Information 4:   f11ee102611de2e7d6b55ef18e6f7478
 
  Problem Event Name:   APPCRASH
  Application Name:   TweakingRegistryBackup.exe
  Application Version:   3.3.0.0
  Application Timestamp:   5616dcb3
  Fault Module Name:   StackHash_cd5f
  Fault Module Version:   0.0.0.0
  Fault Module Timestamp:   00000000
  Exception Code:   c000041d
  Exception Offset:   PCH_25_FROM_USER32+0x00008E71
  OS Version:   6.3.9600.2.0.0.272.7
  Locale ID:   2057
  Additional Information 1:   cd5f
  Additional Information 2:   cd5fd56a31fed298c4fd426ec1a1443d
  Additional Information 3:   688e
  Additional Information 4:   688eb60232939c5a9e69d3d67d5328cd

I've tried a fresh install of Registry Backup but to no effect.

F-4.
Title: Re: Registry Backup has stopped working
Post by: Shane on October 09, 2015, 12:59:36 AM
Very odd, I didnt try it on 2012, just xp, vista, 7, 8 and 10

3.2.3 and 3.3.0 are mainly controls updates, the controls used on the form, textboxes, buttons, tabs and so on.

So obviously the crash is coming somewhere from there. What makes it even more odd is I have never seen the error "PCH_4F_FROM_ntdll" and google pulls up nothing.

But c0000005 means access violation, which means the program or controls tried to access something in memory at a location that wasnt there, then bang crash.

Now on some of the controls I did turn off some safety checks to help speed them up, I tested them on all the OS's before I did, but of course one of the few that I didn't test it on has the crash lol

So since I have no way to tell what thei error message points to the best course of action would be for me to recompile the controls (the ocx and dll files in the program folder) and put the safety checks back on and have you test and we can start from there.

Shoot me an email ( you can get it from this page http://www.tweaking.com/core/imprint/index.html) and I will work with you over email and get a test build done starting with the controls complied again. I am hoping that is all that is needed to fix this, otherwise it is going to be a pain tracing this down lol

it is 1 am for me and I am catching up on work. It wouldn't take me long to do a simple recompile of the controls so I might be able to get you a test build pretty fast.

Shane
Title: Re: Registry Backup has stopped working
Post by: Shane on October 09, 2015, 01:32:29 AM
Actually the best way for me to fix it is if I can replicate it. So I am installing 2012 R2 in vmware now and will see if it crashes for me. If it does then I can use it to test and trace down what is causing the crash on 2012 :-)

Shane
Title: Re: Registry Backup has stopped working
Post by: AndreTriAxis on October 09, 2015, 04:49:59 AM
I still get an error with version 3.3.0 but this time it is a little bit different.
The TweakingRegistryBackup.exe process appears in Task Manager consuming 25% of the processor for about 5 minutes and then opens an alert window: "The program didn't shutdown properly. This may be due a problem with the Volume shadow Copy Service. Would you like to use the Fallback Backup Method instead for future backups? (This uses the Windows API instead of the Volume Shadow Copy)". I answered "No". The TRB window opens for 30 seconds and then crashes.
This happens whether the VSC is started or disabled.
As it worked for some time in the past, I guess it probably stopped working due to a Windows update.

Error:
Problem signature:
  Problem Event Name:   APPCRASH
  Application Name:   TweakingRegistryBackup.exe
  Application Version:   3.3.0.0
  Application Timestamp:   5616dcb3
  Fault Module Name:   OLEAUT32.dll
  Fault Module Version:   6.1.7601.18679
  Fault Module Timestamp:   54754919
  Exception Code:   c0000005
  Exception Offset:   00026b9f
  OS Version:   6.1.7601.2.1.0.274.10
  Locale ID:   1046
  Additional Information 1:   81e3
  Additional Information 2:   81e3d979e6b6c78899103bdd65561461
  Additional Information 3:   81e3
  Additional Information 4:   81e3d979e6b6c78899103bdd65561461

Andre.
Title: Re: Registry Backup has stopped working
Post by: falcon_four on October 09, 2015, 07:22:51 AM
Hi all,

To anyone else with this fault I'm trying a test build that seems to have fixed the immediate crashing issue - which is related to the new interface controls.

A quick test is to rename TweakingSubTmr.dll to something else and then try and load RB.

(The above file is in the RB program directory)

Or wait for Shane to release the new build.

F-4.
Title: Re: Registry Backup has stopped working
Post by: AndreTriAxis on October 09, 2015, 07:33:49 AM
falcon_four, renaming the .dll did not make any difference.
Title: Re: Registry Backup has stopped working
Post by: falcon_four on October 09, 2015, 07:52:07 AM
Hi,

The link for the test build is:

http://www.tweaking.com/files/test_builds/rb_3.3.0_test.zip (http://www.tweaking.com/files/test_builds/rb_3.3.0_test.zip)

(there's no installer, just extract to a folder and run).

See if that helps,

F-4.
Title: Re: Registry Backup has stopped working
Post by: Shane on October 13, 2015, 02:49:14 AM
AndreTriAxis, did that test build work for you?

It worked for falcon_four and is going to be what I release to v3.3.1 and I want to make sure it works for you to see if I need to make any changes.

For him the crash had to do with the subclassing of the mouse events. The new subclass dll I was suing worked fine for me in 2012 and everything else I tried but it wasnt for him. So I recompiled the controls to use the original subclassing dll I have used for years and it worked just like it always had for him.

So no matter what I am putting out the new version in the morning, just hoping I can make any changes before then if any are needed.

Shane