Support Forums

Main Forum => Feedback & Suggestions => Topic started by: Brian.Cryer on January 28, 2016, 08:11:18 AM

Title: Windows 10 works again but ...
Post by: Brian.Cryer on January 28, 2016, 08:11:18 AM
I run two windows 10 machines, one is a dream yet the other has suffered from frequent hangs ever since I upgraded it. The main difference between the two machines was that the good machine was a clean install whereas the one which frequently hung was an upgrade from a well used Windows 8 machine.

The good news is that running your Windows Repair means that my problematic Windows 10 machine no longer hangs. Its stable. It works as it should. Only wish I had discovered it sooner. Brilliant thank you.

But ... after running Windows Repair I couldn't start my virtual machines. I eventually tracked this back to permissions, not on files but on groups. The "Administrators" group had the following local groups added: "NT AUTHORITY\LOCAL SERVICE", "NT AUTHORITY\NETWORK SERVICE", "NT AUTHORITY\SERVICE", "NT AUTHORITY\SYSTEM" and "NT SERVICE\TrustedInstaller". None of those should be there - and removing them meant that my virtual machines could start again. I'm 95% certain that Windows Repair added those, as I've not installed anything else since (but it was a couple of days before I noticed the problem).
Title: Re: Windows 10 works again but ...
Post by: Shane on January 31, 2016, 09:08:13 PM
Yeap, WR added those, it is done first before the repairs. I run VMware and dont have that problem though. What are you using for your virtual machines?

There is a lot of repairs where for some reason on some systems permissions applied to those groups dont always hold or work like they should, and by adding them to administrators they work again. Each one of those should have administrator access anyways so in the 3 or 4 years I have had that in the program I have never seen it cause any problems.

So I am curious to why those being in the admin group would have caused your vm from running. So if tell me what software your using for it and what version I can go do some googling on it and see if I can find an answer :-)

Title: Re: Windows 10 works again but ...
Post by: Brian.Cryer on February 02, 2016, 01:53:05 AM
I'm using (Windows) Hyper-V, which is available to Pro versions of Windows 10.

This forum post was what put me onto it:

I compared with a vanilla windows 10 and removed the extra permissions. I've not tried to work out whether it is only one of the extra permissions that might cause the problem, I just removed all of them. Hope this helps.
Title: Re: Windows 10 works again but ...
Post by: Shane on February 25, 2016, 11:37:51 AM
Sorry for such a late reply! I have been so slammed that this is my first chance to get back to the forums.

If you wouldn't mind testing, could you see if it is a specific one or a combo of them all. While normally it should cause any programs and never has on older version of Windows, Windows 10 is a very fragile OS that breaks easily if things are not perfect as it wants it. For some reason MS rushed to get it out so fast that they havent done much on error handling.

But given how insane Windows 10 is with permissions, such as if the system account isnt the owner of certain registry keys and even though system account still has full access that the app store would break gives you an idea how it is with permissions. This is why I have to do restore to defaults for the permissions. Maybe the command to add those to the administrators account isnt needed on 10 like it was the others and I can have the program skip it for 10.

So if you can confirm which one I can block just it or all of them :-)