Support Forums

Main Forum => General Computer Support => Topic started by: Tony H on April 30, 2019, 11:10:23 AM

Title: Windows 10 won't reboot after running Tweaking in Safe Mode
Post by: Tony H on April 30, 2019, 11:10:23 AM
I have used this product for a few years and have found it to be very useful.  However, after recently using it I can no longer boot into Windows 10.  I'm running Windows 10 on a 240GB SSD drive formatted as MBR with only the OS and program files on it.  My second drive is a 3TB WD drive partitioned as GPT.  It contains my user files and W7 and W8 OS partitions.  I used the SSD as the boot drive to control the three OSes using EasyBCD.  I primarily use W7  most of the time to avoid the nagging Windows updates in Windows 10 when I'm doing video and audio editing.  It has worked fine for the last 5 years with no trouble. 

A few days ago when I booted into Windows 10 there was no taskbar search box and it was difficult to navigate between windows.  So I booted into Safe Mode and ran Tweaking Windows Repair overnight.  The next day I discovered that it had hung at Repair #8 for 9 hours.  I stopped it, unchecked all repairs and the re-checked all except the first 8.  Repair #28 also hung for a long time and I stopped it and proceeded on with the rest.  Then I tried to run these two one at a time and they still hung.  So I closed the program and rebooted to no avail.  I cannot boot to Windows in either active or Safe Modes.  It shows the Windows logo and the rotating circle briefly and then reboots to a black window.  I have tried all of the suggested ways to resurrect it to no avail.  That includes Startup Repair, Command line bootrec repairs [fixmbr, fixboot, ScanOs, RebuildBcd], SFC Scannow, Chkdsk.  I also tried Macrium Reflect's Rescue disk boot repair.  I reset the boot menu and I can boot from Windows 7 and 8 but still cannot boot to Windows 10.  I also tried these things with the GPT disk disconnected using only the SSD disk.

Some time ago I had a similar issue on my other desktop which also runs multi-boot.  One drive would not boot.  In my searching I came across a very short sequence of cmd line commands that addressed the bootrec of the specific OS.  It worked great!  I have searched and searched for it again and have not been able to find it.

Does anybody have any ideas on how to resurrect my Windows 10 install.  If all else fails I have a backup image of it but it's over a year old and I would prefer to recover the current installation.

Title: Re: Windows 10 won't reboot after running Tweaking in Safe Mode
Post by: Boggin on April 30, 2019, 03:08:37 PM
I'm unable to find any cmds that you describe.

See if you can boot into the advanced boot options by power shutting down when the Win 10 logo comes up.

Do that another twice and leave to boot on the third one.

That should give you Preparing Automatic Repair and then Diagnosing your PC.

Click on Advanced options and then on Troubleshoot - Advanced Options

You can either select Command Prompt or Startup Settings for Safe Mode to access Command Prompt (Admin)

Enter bcdedit |find "0sdevice" to see if it still sees it and gives you a partition letter.

That is a Pipe symbol before find and is the uppercase of \

If that gives you a C:\ prompt then enter -

dism /online /cleanup-image /restorehealth


then reboot to see if it will.

If you select Command Prompt from the advanced boot options and it gives you a partition letter, if the dism cmd doesn't work, you can use the back button to select Reset this PC.

This will retain your personal stuff but will remove any installed programs.

Title: Re: Windows 10 won't reboot after running Tweaking in Safe Mode
Post by: Boggin on April 30, 2019, 03:44:10 PM
If the bcdedit cmd gives you a partition letter other than C: then type that letter before entering the dism cmd but on checking this on my 1809 machine, dism won't run from that Command Prompt, so you may just have to select Safe Mode with Networking from Startup Settings for the Command Prompt (Admin).

While you can manually connect wirelessly, if practical, Ethernet connect for an Internet connection.
Title: Re: Windows 10 won't reboot after running Tweaking in Safe Mode
Post by: Tony H on April 30, 2019, 07:32:03 PM
Hi, Tom:

Thank you for your response.  Before posting I read through several posts involving W10 not booting after using the repair software.  I picked up on your suggestion to run bcdedit |find "0sdevice" to see if it still sees it and gives you a partition letter.  It showed the Windows installation on D.  I selected it and ran SFC /Scannow.  It reported no issues.  I tried to run DISM without success.  Apparently you can run it offline.  I started with this:  DISM /image:C:\ /cleanup-image /revertpendingactions found on another website.  I added "offline" to it which helped but I was not able to properly label the location of the windows file using : \ and / combinations.

I still cannot log in to Safe Mode, even trying the method you suggested by shutting down three times.  I was able to get into the recovery console but when I chose to restart and selected Safe Mode it showed the W10 logo screen momentarily and then went to a black screen, which is what it has been doing previously.

As I mentioned, I have a backup copy from December 2018 that I can restore it needed.  But in the last year I have installed software which takes a considerable amount of time to install so I'd like to regain control of the current installation if possible.

I'll keep looking for a little while and then give up and restore the backup.  If you think of anything else I can do, let me know.



Title: Re: Windows 10 won't reboot after running Tweaking in Safe Mode
Post by: Boggin on May 01, 2019, 01:35:51 AM
On two occasions when using a restore point, it hung so I power shut down just to find it wouldn't start up and the only thing that would boot it was a Kaspersky Rescue disk.

After it had done its scan, it then booted up as normal after the reboot.

I'm not sure if this would work for you but you don't have anything to lose by giving it a try.

As the sfc /scannow came back clean, I'm not sure if booting up with Win 10 install media and performing an offboot sfc /scannow would report the same.

You can create Win 10 install media after reading the instructions at

You'll probably need to change the boot order which you can do either from within the BIOS under the Boot menu or you may be able to effect a one off boot change by tapping F12 as you boot up.

If using an USB, I've found it best to insert that before booting so that the machine has time to recognise it.

You would then use the cursor keys in any case to select the type of media you are using.

If using a DVD, insert that and press enter.

If using a DVD then tap any key when prompted to boot from CD/DVD and wait for it to load.

You may be presented with an inverse window with Windows Setup [EMS Enabled] highlighted - just press enter.

Navigate your way to the Install screen and click on Repair your computer where you will see the advanced boot options to select Command Prompt.

Enter the bcdedit |find "osdevice" cmd again and using that partition letter instead of the X I have exampled, enter -

sfc /scannow /offbootdir=X:\ /offwindir=X:\Windows whi

The Win 10 install media can be especially useful as you can perform a repair install should Win 10 go awry, which doesn't affect personal stuff or installed programs.

For future ref. - this is done from within Windows by opening Windows/File Explorer - This PC - insert the install media and double click on its drive.

This will start the process when using a DVD but will open to its files when using an USB where you would then double click on setup Application.

This takes about 4hrs on mine.

As the Windows Repair program has been known to produce anomalous results on some Win 10 machines, I always create a Macrium Reflect system image before test running each new version.
Title: Re: Windows 10 won't reboot after running Tweaking in Safe Mode
Post by: Boggin on May 01, 2019, 01:56:25 AM
I've never used this system but it looks useful as something else to try -
Title: Re: Windows 10 won't reboot after running Tweaking in Safe Mode
Post by: Tony H on May 03, 2019, 12:07:13 AM
Hi, Tom:

Success at last!  Windows 10 is working again!

I first tried your suggestion to run Kapersky's Rescue disk.  It didn't help.  After trying several other things I was finally resigned to restoring my Windows 10 image from 2017 and then doing an inplace upgrade to version 1807.

As I was making final preparations to do so I backed up my personal files from W10 and was considering backing up the Program files.  As I looked down the list of folders in the root directory I came across one just below Program Data labeled "RegBackup."  It had four folders, three from 2018 and one from 4/23/2019.  I opened the last one and discovered what appeared to be a Registry backup for the last time I ran Windows Repair.  It had 3 text files with one labeled log_backup.  It had listed at the bottom with a reference to the first of the 2018 backups and containing the location of the .DAT file for that backup.  It also had a file labeled dos_restore.cmd.

I thought this may be what I was looking for.  I had come to the conclusion that the registry file may have become corrupted when I stopped the two repairs because of the length of time they ran.  I had created a new W10 installation disk a couple of days ago.  The one I had was from 3 years ago when I upgraded to W10.  I thought that might explain why it couldn't repair my installation which was more current.  So I rebooted to it and went to the command prompt.  I navigated to the directory where the registry updates were and into the one from 4/23/2019.  I ran the dos_restore.cmd and rebooted.  Windows 10 opened without any further problems.

I quickly ran full backups of W10 with both Acronis and Macrium.  I'm not taking any chances.  My next step will run the "in-place" upgrade to Windows 10 version 1807.

This method will probably work for others who find themselves in this situation.

One more thing . . .

I found the method I was looking for in a text message I created.  Here it is:

Boot with Windows installation DVD, select repair and open a command prompt.

Type diskpart

Type select disk 0

Type list partition

then note the partition number where you installed windows.

You may need to list volume to identify the letter of the windows installation.

Type select partition X    (X is the partition number where Windows is installed)

type active

type exit

type bcdboot x:\windows     (where x is the letter of your windows partition)

I have found that this works when the bootrec commands do not.

Title: Re: Windows 10 won't reboot after running Tweaking in Safe Mode
Post by: Boggin on May 03, 2019, 12:19:53 AM
That's good news and glad you were able to get back up, but I was wondering how you were able to access your files when Win 10 wouldn't boot.
Title: Re: Windows 10 won't reboot after running Tweaking in Safe Mode
Post by: Tony H on May 03, 2019, 09:41:43 AM
Hi, Tom:

I was able to access my files from the command prompt using the W10 installation disk repair option.  You can go anywhere you want to and can even copy files to an external drive if you wish.  It's not as easy as being online and just clicking away.  You have to navigate through the directories using DOS commands.  With my GPT drive disconnected and only my SSD drive with W10 it was relatively easy,  At the D prompt I typed DIR and immediately saw "RegBackup" in the list.  The I did CD \RegBackup and saw the five entries containing registry backups made by  I just selected the most current one dated 4/23/2019 and opened it and ran the restore command.

If you're asking how I could see my files with W10 not booting it is becauae I'm running a triple boot system with W10, W8 and W7.  The other two OSes are on the GPT drive but boot off of the SSD drive which is formatted as MBR.  When one isn't booting I can still use the other two.  Sometimes I have to reset the BCD. 

Title: Re: Windows 10 won't reboot after running Tweaking in Safe Mode
Post by: Boggin on May 03, 2019, 01:00:56 PM
Okay - Thanks.