Tweaking.com Support Forums

Main Forum => Tweaking.com Support & Help => Topic started by: Wiley1 on June 20, 2021, 12:04:28 PM

Title: WR AIO hosed my Server 2016 Essentials
Post by: Wiley1 on June 20, 2021, 12:04:28 PM
I was seeing too many entries in BPA so I decided to run Windows Repair.  Huge mistake.  The system would do nothing but blank screen after reboot.  I had to get in my car and drive 3 hours to recover.   After performing a "last known good configuration", it now boots but Server Manager hangs at the collection phase.

Now I need a little advice.  Can this patient be saved?

Title: Re: WR AIO hosed my Server 2016 Essentials
Post by: Boggin on June 20, 2021, 02:31:53 PM
I'll ask Shane.

What is BPA ?
Title: Re: WR AIO hosed my Server 2016 Essentials
Post by: Wiley1 on June 20, 2021, 02:42:19 PM
Best Practices Analyzer, integrated into Server Manager.   Locates configuration issues and suggests remedies.   I stopped reading after the first 10.  There must have been more than 30.  Not your fault.   

Title: Re: WR AIO hosed my Server 2016 Essentials
Post by: Boggin on June 20, 2021, 03:00:52 PM
I've emailed Shane to see if there are any compatibility issues with WR and your version of Windows.

Do you have any restore points that will take you back to before you ran WR ?

Prior to running the repairs, WR creates a registry back up which you could restore to, to see if that gets things working normally for you.

It's accessed through Backup Tools.
Title: Re: WR AIO hosed my Server 2016 Essentials
Post by: Wiley1 on June 21, 2021, 04:45:27 AM
Windows Server 2016 Essentials is a complicated little bear.  It is basically Server 2016 with limited built-in licensing.
Active Directory and DNS are automatically installed so it becomes the Primary Domain Controller.
I'm reading that WR tends to choke on Domain Controllers.

At this point, I have gotten it to boot to the desktop, but the AD and DNS roles aren't behaving correctly.

Title: Re: WR AIO hosed my Server 2016 Essentials
Post by: Boggin on June 21, 2021, 06:08:47 AM
Yes, I came across an old WR thread where someone had problems with WR on a Server version.

Open WR then click on Backup Tools then on Restore under Registry Backup.

Click on Registry Restore then use the dropdown to select the dated back up then hit Restore Now.

If that doesn't get you back then open a Command Prompt (Admin) or Powershell (Admin) and enter these cmds -

dism /online /cleanup-image /restorehealth

sfs /scannow

ipconfig /flushdns

ipconfig /registerdns

shutdown /r /t 00

Then see what it's like after the reboot.
Title: Re: WR AIO hosed my Server 2016 Essentials
Post by: Boggin on June 22, 2021, 02:19:36 PM
I've had a reply back from Shane in that WR is not compatible with Server versions of Windows as the Permissions on those are different.

He also told me that he's going to include that warning in a future WR update.

Were you able to get your machine back to normal using WR's Registry Backup or the cmds I suggested ?