Tweaking.com Support Forums

Main Forum => Tweaking.com Support & Help => Topic started by: neroilo on July 29, 2021, 06:47:59 AM

Title: Follow-up of translation issue since WR installer 4.11.x
Post by: neroilo on July 29, 2021, 06:47:59 AM
I just wanted to report that the following issue wasn't fixed in v4.11.4 and v4.11.5:
https://www.tweaking.com/forums/index.php/topic,6773.0.html
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on July 29, 2021, 01:29:46 PM
I passed a link to your thread to Shane but didn't get a reply.

You can still select your language after installation - perhaps Shane considers that is all that is necessary.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on July 30, 2021, 11:28:17 AM
I passed a link to your thread to Shane but didn't get a reply.

You can still select your language after installation - perhaps Shane considers that is all that is necessary.

The problem is that the installer is always forced in my italian language, no matter if I set english language after installation.
It could be annoying for other users that don't know what to do with those checkboxes with labels set as Opzione1 and Opzione2.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on July 30, 2021, 01:58:52 PM
I haven't seen Opzione1 and Opzione2.

Mine defaults to English as I'm in the UK but I changed the language to Italian and it immediately changed to that language and stayed there.

Have you tried reinstalling the program ?
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on July 30, 2021, 02:08:08 PM
I haven't seen Opzione1 and Opzione2.

Mine defaults to English as I'm in the UK but I changed the language to Italian and it immediately changed to that language and stayed there.

Have you tried reinstalling the program ?

I tried uninstalling and reinstalling and it didn't work.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on July 30, 2021, 02:39:11 PM
I'll email Shane again with a link to this thread.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on August 01, 2021, 05:08:38 AM
I'll email Shane again with a link to this thread.

Ok, in case you get a reply please let me know here.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 01, 2021, 02:41:26 PM
I have asked Shane to reply in the thread but not sure when the reply will come as I also linked another thread for him to look at.

Hopefully he will be looking at both but if I don't see or get a reply in a week, I'll email him again.

He is very busy as he also has a computer repair business to run.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 09, 2021, 01:37:06 AM
I've sent another email sent this morning, but as I'm 8hrs ahead of him, not sure if or when he picks it up.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 10, 2021, 08:39:25 AM
Shane's working on it.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on August 12, 2021, 01:22:31 PM
I've tested 4.11.6 released today, and I can confirm the bug on this version too.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 12, 2021, 01:36:05 PM
This is Shane's reply -

 I don?t seem to have anything to check and autoset the language, but the setting for it is in the settings.ini file in the program folder, also he should be able to simply change it on the main window of the program.

 I've emailed Shane again explaining that it's auto resetting back from English to Italian.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 12, 2021, 01:46:00 PM
This is Shane's reply to my last email - can you post that pic ?

That is extremely odd, unless there is a problem with how the program is trying to set the combo box. But I don't see why it could. But something is happening for it to be auto set like that. As you seen from the code I sent it sets the drop down via text and not by index. I wonder if his system his changing the way the text is being shown, that would explain it.
Can you get screenshots from him showing the drop down box open so we can see how the text looks?
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on August 13, 2021, 04:11:34 AM
This is Shane's reply to my last email - can you post that pic ?

That is extremely odd, unless there is a problem with how the program is trying to set the combo box. But I don't see why it could. But something is happening for it to be auto set like that. As you seen from the code I sent it sets the drop down via text and not by index. I wonder if his system his changing the way the text is being shown, that would explain it.
Can you get screenshots from him showing the drop down box open so we can see how the text looks?

Here below I attached the screenshot of drop-down box open in the main program, my W10 custom scaling settings in the second attachment and the italian translation issue in the third attachment.
My screen resolution is 2560x1440.

Do you think there is a relation with the missing italian options descriptions in the third attachment?
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 13, 2021, 07:20:28 AM
I've emailed Shane with a link to your thread.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 13, 2021, 10:10:11 AM
Shane has suggested that you try the portable version for comparison.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on August 13, 2021, 10:26:11 AM
Shane has suggested that you try the portable version for comparison.

Here below I attached the screenshot of drop-down box open in the portable program:
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 13, 2021, 10:35:10 AM
Does that also auto reset to Italian ?
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on August 13, 2021, 02:07:25 PM
Does that also auto reset to Italian ?

Nope, the portable version looks fine. It was english at first and I changed it to italian.
I don't think it has something to do with the installer issue.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 13, 2021, 03:15:36 PM
I'll pass that onto Shane.

That may help him pinpoint what is happening in your case.

WR is working fine for me, so if Shane is unable to replicate it on his machine then it may be very difficult for him to resolve if it is peculiar to your machine.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on August 16, 2021, 03:08:48 AM
I'll pass that onto Shane.

That may help him pinpoint what is happening in your case.

WR is working fine for me, so if Shane is unable to replicate it on his machine then it may be very difficult for him to resolve if it is peculiar to your machine.

In addition to my real Windows 10 machine, I was able to replicate it on a Windows 10 vm with these language settings set in the first Windows setup.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 16, 2021, 06:10:44 AM
I haven't had anything back from Shane yet.

I'll give him a bump in a few days time.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 18, 2021, 12:45:30 PM
I was trying to send Shane a bump email but my email seems to be playing up.

I'll try again in the morning.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 19, 2021, 01:57:46 AM
email sent and replied to.

Shane is having problems with this as he's unable to replicate it.

Should the problem be with your Windows can you open a Command Prompt (Admin) or Powershell (Admin) and run these cmds - letting me know what they report.

dism /online /cleanup-image /restorehealth

sfc /scannow

Enter exit to close the cmd wind and try WR again.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on August 19, 2021, 06:03:42 AM
email sent and replied to.

Shane is having problems with this as he's unable to replicate it.

Should the problem be with your Windows can you open a Command Prompt (Admin) or Powershell (Admin) and run these cmds - letting me know what they report.

dism /online /cleanup-image /restorehealth

sfc /scannow

Enter exit to close the cmd wind and try WR again.

The output of those commands reported that no issue was found and WR has still the same issue.
Is it ok if I send you a PM with a download link containing the VM with the WR installer issue?
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 19, 2021, 06:19:24 AM
Can you post the link and I'll pass it onto Shane.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 20, 2021, 07:42:34 AM
I'm waiting of a reply from Shane after he has had a look at your VM link.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 22, 2021, 02:44:51 PM
If I haven't had anything back from Shane by Monday I'll give him a bump email on Tuesday.

I don't think he does anything over the weekend.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 24, 2021, 11:49:39 AM
Wasn't sure if Shane would have found anything in a day or two so will email him tomorrow.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 25, 2021, 11:48:33 AM
I've emailed him but he hasn't found the cause yet although he's still working on it.

It makes it very difficult when you can't replicate the fault.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on August 25, 2021, 07:48:08 PM
I've emailed him but he hasn't found the cause yet although he's still working on it.

It makes it very difficult when you can't replicate the fault.

Since he already downloaded the file, I have removed it from my cloud storage.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 27, 2021, 01:51:02 AM
Shane has been working on a workaround which he thinks will resolve and will be incorporating it into an updated version of WR.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 28, 2021, 01:41:37 PM
Version 4.11.7 now available.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on August 28, 2021, 05:10:17 PM
Version 4.11.7 now available.

Just tested, the issue is still there.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 29, 2021, 01:08:44 AM
I'll let Shane know.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 29, 2021, 03:08:07 AM
Shane is at a loss in how to fix it as he doesn't know what is causing it even though he knows the program inside and out.

I would think he will try to dig deeper in trying to find a solution, but don't know how long that will take.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on August 31, 2021, 01:32:10 PM
Can you try changing the language on your machine to English then use WR's dropdown to change it to Italian to see how that goes.

https://www.google.co.uk/url?sa=t&rct=j&q=&esrc=s&source=web&cd=&ved=2ahUKEwirz-iThNzyAhWZEMAKHYm0D8QQFnoECAMQAw&url=https%3A%2F%2Fwww.windowscentral.com%2Fhow-properly-change-system-default-language-windows-10&usg=AOvVaw2oeUmFJs_Tu3vVFm9OvLJ-

You can change it back to Italian when done.

I've noticed that you are located in the UK.

If you are Italian, why do you want to run WR in English mode ?
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on August 31, 2021, 07:31:52 PM
I've noticed that you are located in the UK.

If you are Italian, why do you want to run WR in English mode ?

My main concern is about the Windows Repair installer in italian that doesn't reproduce the correct options at the end of the installation.. if you're struggling about how to fix them, I'd be grateful if you can provide a language selector like this (https://clients.bitrock.com/installbuilder/docs/installbuilder-userguide/images/language-selection-default.png) in the WR installer, that would help me a lot to bypass the issue by selecting the English language. Basically I would like to switch the installer language without setting another Windows language.

Can you try changing the language on your machine to English then use WR's dropdown to change it to Italian to see how that goes.

https://www.google.co.uk/url?sa=t&rct=j&q=&esrc=s&source=web&cd=&ved=2ahUKEwirz-iThNzyAhWZEMAKHYm0D8QQFnoECAMQAw&url=https%3A%2F%2Fwww.windowscentral.com%2Fhow-properly-change-system-default-language-windows-10&usg=AOvVaw2oeUmFJs_Tu3vVFm9OvLJ-

You can change it back to Italian when done.

I made a few tests, and this (https://www.top-password.com/blog/wp-content/uploads/2017/02/change-system-locale.png) was the Windows setting that changed the WR installer language to English.

The installer options are finally rendered correctly with just that setting set to English... but it was annoying to reach, and I would prefer a quicker language selector in the installer as specified above.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on September 01, 2021, 01:26:56 AM
I don't know if Shane will be able to incorporate those into WR, but I'll pass those onto Shane.

Neither Shane or myself can replicate what you have been getting, so I had been wondering if the problem was machine specific.

I'll let you know what he replies when he does.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on September 01, 2021, 02:21:02 AM
Those settings are machine specific so they couldn't be incorporated into WR.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on September 01, 2021, 07:10:08 AM
Those settings are machine specific so they couldn't be incorporated into WR.

I think I explained myself badly, I didn't mean to say to include that Windows language setting in the WR installer, I just wanted to say if you could add an additional language selector to override the default system locale of Windows (only for the installer strings). With a language selector, I could switch the installer strings in any language whenever I want when I run the WR installer every single time.

I have no idea of the installer that WR uses, but in Inno Setup it could be done with an additional parameter (set to yes):
https://jrsoftware.org/ishelp/index.php?topic=setup_showlanguagedialog
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on September 01, 2021, 07:12:57 AM
I'll pass on your suggestion to Shane.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on September 01, 2021, 01:16:18 PM
Shane has told me that he'll be working on that today and release an updated WR version.

He's going away for about a week but while it could be a rush job, I'm sure it will be thorough.

Keep your eyes open for a newer version or I'll let you know when I get the notification of an update through my Pro version.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on September 02, 2021, 01:13:33 AM
Shane has found that he needs to do some more investigative work on this before he can produce an update to the program.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on September 07, 2021, 08:13:36 AM
Shane told me he would be out of town between the 2nd and the 7th so you will have to wait for him to get back on this.

I'll email him on the 9th if I haven't had anything back by then.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on September 11, 2021, 12:22:33 PM
I emailed Shane on the 9th and he thinks as he's working in English, that may be why he's unable to replicate it.

I've suggested he contact a recent new member from France to check this on their machine but as yet, not had any further contact from Shane.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on September 17, 2021, 07:30:42 AM
I've emailed Shane about a recent new member also from Italy.

I've suggested he email him to see if he has the same problem on his machine.

I'm waiting for a reply.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on September 20, 2021, 02:42:46 PM
I've had a reply from Shane but it isn't good news.

He's informed me that he is very ill with covid.

I'm sure we all wish him a speedy recovery but any WR queries will go unanswered unless I can address them.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: neroilo on September 21, 2021, 04:43:04 AM
I sincerely hope he gets well soon.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on September 21, 2021, 10:48:50 AM
I've had another email from Shane who told me that his breathing is okay and that he doesn't have a fever, although he's feeling crap - for want of a better word.

Hopefully it won't be too long before he's fully recovered.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on October 11, 2021, 01:32:41 PM
Shane is now fully recovered so I've asked him to have a look at your thread.

He does have a lot of work to catch up on so there could be a delay in his response.
Title: Re: Follow-up of translation issue in WR installer 4.11.x
Post by: Boggin on November 12, 2021, 09:15:43 AM
Bump - to keep the thread open.
Title: Re: Follow-up of translation issue since WR installer 4.11.x
Post by: neroilo on November 27, 2021, 04:28:52 PM
This is still an issue on version 4.12.1.
Title: Re: Follow-up of translation issue since WR installer 4.11.x
Post by: Boggin on November 28, 2021, 01:08:26 AM
I'll be emailing Shane on Wednesday to see if his personal problems are now over as I explained in a PM to you.

I'll include a link to your email when I do so that he can contact you direct.