Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - neroilo

Pages: [1] 2 3 ... 7
1
I'll be emailing Shane on Wednesday to see if his personal problems are now over as I explained in a PM to you.

I'll include a link to your email when I do so that he can contact you direct.

I'm looking forward to it.

2
This is still an issue on version 4.12.1.

3
I sincerely hope he gets well soon.

4
Those settings are machine specific so they couldn't be incorporated into WR.

I think I explained myself badly, I didn't mean to say to include that Windows language setting in the WR installer, I just wanted to say if you could add an additional language selector to override the default system locale of Windows (only for the installer strings). With a language selector, I could switch the installer strings in any language whenever I want when I run the WR installer every single time.

I have no idea of the installer that WR uses, but in Inno Setup it could be done with an additional parameter (set to yes):
https://jrsoftware.org/ishelp/index.php?topic=setup_showlanguagedialog

5
I've noticed that you are located in the UK.

If you are Italian, why do you want to run WR in English mode ?

My main concern is about the Windows Repair installer in italian that doesn't reproduce the correct options at the end of the installation.. if you're struggling about how to fix them, I'd be grateful if you can provide a language selector like this in the WR installer, that would help me a lot to bypass the issue by selecting the English language. Basically I would like to switch the installer language without setting another Windows language.

Can you try changing the language on your machine to English then use WR's dropdown to change it to Italian to see how that goes.

https://www.google.co.uk/url?sa=t&rct=j&q=&esrc=s&source=web&cd=&ved=2ahUKEwirz-iThNzyAhWZEMAKHYm0D8QQFnoECAMQAw&url=https%3A%2F%2Fwww.windowscentral.com%2Fhow-properly-change-system-default-language-windows-10&usg=AOvVaw2oeUmFJs_Tu3vVFm9OvLJ-

You can change it back to Italian when done.

I made a few tests, and this was the Windows setting that changed the WR installer language to English.

The installer options are finally rendered correctly with just that setting set to English... but it was annoying to reach, and I would prefer a quicker language selector in the installer as specified above.

6
Version 4.11.7 now available.

Just tested, the issue is still there.

7
I've emailed him but he hasn't found the cause yet although he's still working on it.

It makes it very difficult when you can't replicate the fault.

Since he already downloaded the file, I have removed it from my cloud storage.

8
email sent and replied to.

Shane is having problems with this as he's unable to replicate it.

Should the problem be with your Windows can you open a Command Prompt (Admin) or Powershell (Admin) and run these cmds - letting me know what they report.

dism /online /cleanup-image /restorehealth

sfc /scannow

Enter exit to close the cmd wind and try WR again.

The output of those commands reported that no issue was found and WR has still the same issue.
Is it ok if I send you a PM with a download link containing the VM with the WR installer issue?

9
I'll pass that onto Shane.

That may help him pinpoint what is happening in your case.

WR is working fine for me, so if Shane is unable to replicate it on his machine then it may be very difficult for him to resolve if it is peculiar to your machine.

In addition to my real Windows 10 machine, I was able to replicate it on a Windows 10 vm with these language settings set in the first Windows setup.

10
Does that also auto reset to Italian ?

Nope, the portable version looks fine. It was english at first and I changed it to italian.
I don't think it has something to do with the installer issue.

11
Shane has suggested that you try the portable version for comparison.

Here below I attached the screenshot of drop-down box open in the portable program:

12
This is Shane's reply to my last email - can you post that pic ?

That is extremely odd, unless there is a problem with how the program is trying to set the combo box. But I don't see why it could. But something is happening for it to be auto set like that. As you seen from the code I sent it sets the drop down via text and not by index. I wonder if his system his changing the way the text is being shown, that would explain it.
Can you get screenshots from him showing the drop down box open so we can see how the text looks?

Here below I attached the screenshot of drop-down box open in the main program, my W10 custom scaling settings in the second attachment and the italian translation issue in the third attachment.
My screen resolution is 2560x1440.

Do you think there is a relation with the missing italian options descriptions in the third attachment?

13
I've tested 4.11.6 released today, and I can confirm the bug on this version too.

14
I'll email Shane again with a link to this thread.

Ok, in case you get a reply please let me know here.

15
I haven't seen Opzione1 and Opzione2.

Mine defaults to English as I'm in the UK but I changed the language to Italian and it immediately changed to that language and stayed there.

Have you tried reinstalling the program ?

I tried uninstalling and reinstalling and it didn't work.

16
I passed a link to your thread to Shane but didn't get a reply.

You can still select your language after installation - perhaps Shane considers that is all that is necessary.

The problem is that the installer is always forced in my italian language, no matter if I set english language after installation.
It could be annoying for other users that don't know what to do with those checkboxes with labels set as Opzione1 and Opzione2.

17
I just wanted to report that the following issue wasn't fixed in v4.11.4 and v4.11.5:
https://www.tweaking.com/forums/index.php/topic,6773.0.html

18
My default is for English so I can't replicate what you are seeing upon installation.

When you open WR there is a dropdown to change to English, German, Italian or French.

I'll pass your concerns onto Shane.

BTW - there is now a new version of 4.11.3

I'm using 4.11.3 and my suggestion is about a new language selector in the installer itself.

19
The italian translation included in "tweaking.com_windows_repair_aio_setup.exe" installer doesn't have the proper options descriptions at the end of the installation (Opzione 02 and Opzione 01, as shown in the following attachment).

It can be reproduced on my Windows system with native italian language since v4.11.0, so I don't know if the same issue happens for other languages.

I would also recommend to add a language selector at the beginning of the installation, in order to select english language when necessary and avoid this kind of inconvenient in future.

20
I am still stuck 5 hours away from home because of my 10 year old daughters softball tournament lol

If they lose again today they are done and I will be coming home tonight, but if they win and dont lose again they could be here till friday. i am really hoping that doesnt happen lol

Shane

Any news?

21
Ok good, then that means we can focus on what is happening during the program startup.

I am about to head out the door, my 10 year old daughter won her all star softball game and so now I have to drive 5 hours to Portland to take her to a tournament game lol

So i wont be back till Sunday. Remind me on monday and I will make a special build of the registry backup where I will add a message box, or have the program log to a text file a number, like 1 then 2 and then 3 and so on. Then that way we see what the last number is we see before it crashes. That will tell me where in the startup to look :-)

Shane

Up!

22
OK, so do any of the other programs on my site crash as well? The windows repair, technicians toolbox and any of the smaller tools?

Reason why I ask is, if they all crash as well (They are all written in old school vb6) then that means there is something up with the vb6 runtimes or what they are linking to. But if the others run fine and it is only the registry backup, then I can at least start by testing each of the commands and api calls the program makes in its startup process. At least this way I will have a direction to go :wink:

Shane

Tweaking Repair runs well, I still use it without issues.

23
I totally forgot about this lol

I am unable to replicate the problem, so it makes it hard for me to find out what is going on and how to fix it.

Refresh my memory, does the program crash right away or after doing a backup?

Shane

For some unknown reason now it crashes right away... no time to load the interface.
I posted new crash dumps here, but just in case I have another list of dmp files for you (in attachment).

24
Tweaking.com Support & Help / Re: TweakingRegistryBackup 2.2.0 crash
« on: July 15, 2015, 04:34:47 AM »
Done, and.... done :-)

Shane

The same thing I would like to read about my issue.

 :cheesy:

25
Tweaking.com Support & Help / Re: TweakingRegistryBackup 2.2.0 crash
« on: July 03, 2015, 02:11:11 PM »
Sure am :-)

My office is finished being built in my garae and so will be moving my desk and crap into there tonight after my daughters softball game, tomorrow is my 36th birthday and then spend all day sunday unpacking. Will be back to a more normal schedule sometime next week  :cheesy:

Shane

No problem, just let me know when you're ready.

Pages: [1] 2 3 ... 7