Author Topic: Opening Documents Slow  (Read 7879 times)

0 Members and 1 Guest are viewing this topic.

Offline Oscar

  • Full Member
  • ***
  • Join Date: Dec 2012
  • Posts: 220
  • Karma: 0
    • View Profile
Opening Documents Slow
« on: June 05, 2013, 01:31:06 AM »
Hi when i open documents it takes awhile to open.

But when i open it again it opens faster.

Turn computer off, restart and do the same thing and slow again.

Why is this, can it be fixed?

Thanks in advance

Offline Willy2

  • Hero Member
  • *****
  • Join Date: Oct 2011
  • Posts: 1146
  • Karma: 18
    • View Profile
Re: Opening Documents Slow
« Reply #1 on: June 05, 2013, 02:38:44 PM »
What kind of documents ? Text , PDF, *.ppx, ..... ? And with what programs ? MS Word, Open Office, Foxit PDF reader, Powerpoint (viewer), ....... ?

Sounds like your AV is slowing down the opening of files. Do you have multple AV programs running ? E.g. WinDefender & AVAST ? If you have e.g. AVAST AV you can disable the WinDefend Service.

Offline Oscar

  • Full Member
  • ***
  • Join Date: Dec 2012
  • Posts: 220
  • Karma: 0
    • View Profile
Re: Opening Documents Slow
« Reply #2 on: June 05, 2013, 03:47:50 PM »
Thank you for your reply

PDF, Microsoft Office Documents Word, Access etc, Outlook, Note pad seems to be pretty good.

Also when i close the email it can take awhile before i can open/work with the computer.

Just have Avast?

How do i disable the Windend Services?

Thanks again

Offline Willy2

  • Hero Member
  • *****
  • Join Date: Oct 2011
  • Posts: 1146
  • Karma: 18
    • View Profile
Re: Opening Documents Slow
« Reply #3 on: June 05, 2013, 04:49:56 PM »
If the AVAST firewall (or another brand of firewall) is already running on your computer then you can disable the Microsoft Firewall (Service) as well. Here's one way to do it. Use Tweaking.com's "Window Repair" (WR) !!!

1. make the following changes in the file "Services_startup.txt" (in a subfolder of WR).
- "sc config MpsSvc start= automatic"   ===>   "......... start= disabled" (MS Firewall).
- "sc config WinDefend start= automatic"   ===>   "......... start= disabled" (MS Windows Defender).
2. Tick the box "Set services to default ........." in WR.
3. Run WR & restart your computer. Done.
Following this procedure allows WR in the future to repair your MS Firewall but then the MS Firewall simply remains switched off.

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Opening Documents Slow
« Reply #4 on: June 05, 2013, 10:28:40 PM »
Disable the antivirus completely and see if it speeds things up.

Shane

Offline Willy2

  • Hero Member
  • *****
  • Join Date: Oct 2011
  • Posts: 1146
  • Karma: 18
    • View Profile
Re: Opening Documents Slow
« Reply #5 on: June 05, 2013, 10:37:17 PM »
@Oscar: Do you have AVAST ? If yes, then only activate the "behaviour" & "file" shield.

Offline Oscar

  • Full Member
  • ***
  • Join Date: Dec 2012
  • Posts: 220
  • Karma: 0
    • View Profile
Re: Opening Documents Slow
« Reply #6 on: June 07, 2013, 05:09:31 PM »
Disable the antivirus completely and see if it speeds things up.

Shane

Thanks

Hi Shane yes it does, not fast but an improvement.

Offline Oscar

  • Full Member
  • ***
  • Join Date: Dec 2012
  • Posts: 220
  • Karma: 0
    • View Profile
Re: Opening Documents Slow
« Reply #7 on: June 07, 2013, 05:11:31 PM »
@Oscar: Do you have AVAST ? If yes, then only activate the "behaviour" & "file" shield.

Thank you

Yes i think these are the current settings, i think Shane said to set Avast to these settings in a prevoius thread i posted?

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Opening Documents Slow
« Reply #8 on: June 08, 2013, 11:12:03 AM »
Every antivirus slows down opening files a bit, since they scan everything you open.

Microsoft is the slowest scanner on the market and causes the most slow down, Avast has the faster scanner on the market, so while still a slow down it isn't as much as others.

Other factors come into play, such as the hard drive as you have to wait for it to read the file.

Shane

Offline Willy2

  • Hero Member
  • *****
  • Join Date: Oct 2011
  • Posts: 1146
  • Karma: 18
    • View Profile
Re: Opening Documents Slow
« Reply #9 on: June 08, 2013, 12:03:56 PM »
Another possibility: when Windows reads files from disk then it places the files in the filecache first before making them available to a program. That's why reading files for a second time takes less time. Try if collapsing the filecache (with e.g. CLEANMEM) causes a slowdown in reading the same file(s). If that's the case then I would start to think your harddisk is ageing.
« Last Edit: June 08, 2013, 12:20:05 PM by Willy2 »