Author Topic: Windows Firewall won't Start - SOLVED!!!  (Read 30788 times)

0 Members and 1 Guest are viewing this topic.

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Windows Firewall won't Start
« Reply #25 on: May 13, 2014, 10:40:31 AM »
In that last screen shot you will see the regkey Depends on service, go check each of those services as well and see if their permissions are different :wink:

Shane

Offline Wiloroc

  • Newbie
  • *
  • Join Date: Mar 2014
  • Posts: 21
  • Karma: 0
    • View Profile
Re: Windows Firewall won't Start
« Reply #26 on: May 20, 2014, 05:33:55 PM »
I have tried to reply three times before this with out the result of the reply going through.  Do not know why.

I did what you said to do with the permissions and traced all of the "depends" on items.  I have a bunch of screen shots that I have loaded too many times to do it again.

I will load a couple here now if you want to see specific ones let me know.

Still no change in the fire wall performance.


Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Windows Firewall won't Start
« Reply #27 on: May 21, 2014, 11:33:46 AM »
I wouldnt mind taking a look at this and see if I can find why it wont start, if I can find the reason then I might be able to add it to my Windows Repair :-)

Send me an email

shane at tweaking.com

and I will use teamviewer and connect and work with you on it. At this point I am really curious to what the problem is.

Shane

Offline Wiloroc

  • Newbie
  • *
  • Join Date: Mar 2014
  • Posts: 21
  • Karma: 0
    • View Profile
Re: Windows Firewall won't Start - SOLVED!!!
« Reply #28 on: May 25, 2014, 12:27:38 PM »
Wow, my computer is running faster than I can ever remember!

The firewall is responding as advertised and is catching up with all my programs quickly and appropriately.

GREAT JOB, SHANE!!! :smiley: :smiley: :smiley: :smiley:

Offline Bubba Euler

  • Full Member
  • ***
  • Join Date: Jan 2012
  • Posts: 106
  • Karma: 5
    • View Profile
Re: Windows Firewall won't Start - SOLVED!!!
« Reply #29 on: May 25, 2014, 01:51:46 PM »
Shane, I'm really curious as to what solved the Windows Firewall problem, here.  I read all two pages and suddenly the problem was solved.  What was it?  Is there a lesson for us all or a singular occurrence?  Just trying to learn a little something along the way.... ~ha~!

Offline Wiloroc

  • Newbie
  • *
  • Join Date: Mar 2014
  • Posts: 21
  • Karma: 0
    • View Profile
Re: Windows Firewall won't Start - SOLVED!!!
« Reply #30 on: May 25, 2014, 09:03:55 PM »
I think I was supposed to post all of these for Shane after he repaired my firewall:

[Shane] OK so i went through the two files and compared them on my test stations.

These reg keys are not in my reg file and are not any of my systems. I am going to see if my firewall breaks when i add these registry keys. And if so I will have my repair remove them  (See below - "Whole set of keys from reg file".)

[Shane]
Yep! I applied those registry keys and my firewall is broken. I will remove 1 key at a time and see which one gets it working and get an update of the Windows repair out :-D

[Shane]
OK I deleted the first one and my firewall started right up!

This is the key that broke your firewall. The other keys don't seem to be hurting the firewall but since they are not on a normal system I might remove them as well.



*******
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\ConSecRules]
"{9C3AA536-7CE1-46E1-90FC-F9EF3A461776}"="v2.10|Action=Secure|Active=TRUE|EP2_4=172.22.2.1-172.22.2.255|EP2_4=192.168.1.1-192.168.1.254|EP2_4=172.21.1.1-172.21.1.254|LTunnel4_2=0.0.0.0|Name=Office hook up|Desc=|Auth1Set={2AA5D397-6DA6-4E80-9D5E-52D7A6F0EC04}|Crypto2Set={E5A5D32A-4BCE-4e4d-B07F-4AB1BA7E5FE2}|EmbedCtxt=|"

*********
[Wiloroc]
I removed them all!  If I need them the system will tell me or add them back in.

*********
Whole set of keys from reg file

**********
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\ConSecRules]
"{9C3AA536-7CE1-46E1-90FC-F9EF3A461776}"="v2.10|Action=Secure|Active=TRUE|EP2_4=172.22.2.1-172.22.2.255|EP2_4=192.168.1.1-192.168.1.254|EP2_4=172.21.1.1-172.21.1.254|LTunnel4_2=0.0.0.0|Name=Office hook up|Desc=|Auth1Set={2AA5D397-6DA6-4E80-9D5E-52D7A6F0EC04}|Crypto2Set={E5A5D32A-4BCE-4e4d-B07F-4AB1BA7E5FE2}|EmbedCtxt=|"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\DomainProfile]
"DefaultInboundAction"=dword:00000001
"DefaultOutboundAction"=dword:00000000
"DisableUnicastResponsesToMulticastBroadcast"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\Phase1AuthenticationSets]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\Phase1AuthenticationSets\Anonymous]
"Version"="2.10"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\Phase1AuthenticationSets\Anonymous\0000]
"Method"="Anonymous"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\Phase1AuthenticationSets\{2AA5D397-6DA6-4E80-9D5E-52D7A6F0EC04}]
"Version"="2.10"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\Phase1AuthenticationSets\{2AA5D397-6DA6-4E80-9D5E-52D7A6F0EC04}\0000]
"CAName"="C=SE, O=AddTrust AB, OU=AddTrust External TTP Network, CN=AddTrust External CA Root"
"CertAccountMapping"="FALSE"
"ExcludeCAName"="FALSE"
"HealthCert"="FALSE"
"Method"="MachineCert"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\Phase2AuthenticationSets]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\Phase2AuthenticationSets\EmptySet]
"Version"="2.10"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\PublicProfile]
"DefaultInboundAction"=dword:00000001
"DefaultOutboundAction"=dword:00000000


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\RestrictedServices\Configurable]
"PolicyVersion"=dword:0000020a

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\StandardProfile]
"DefaultInboundAction"=dword:00000001
"DefaultOutboundAction"=dword:00000000




Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Windows Firewall won't Start - SOLVED!!!
« Reply #31 on: May 27, 2014, 10:55:53 AM »
I applied the changes to the new version of the Windows Repair to remove those registry keys now since they are not normally on a system for the Windows firewall :-)

The one that killed his firewall was

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Parameters\FirewallPolicy\ConSecRules

Shane