Author Topic: laptop "hiccups"  (Read 12530 times)

0 Members and 1 Guest are viewing this topic.

Offline duwango

  • Newbie
  • *
  • Join Date: Aug 2014
  • Posts: 1
  • Karma: 0
    • View Profile
laptop "hiccups"
« on: August 14, 2014, 06:33:03 PM »
Howdy y'all.

Running Windows 7 64-bit on a Toshiba Qosmio laptop, and for the past 2 weeks or so, I've been experiencing what I can only describe as being "hiccups". That is , my computer lags for what appears to be a split second for every moment or so. It's more noticable and irritating when I'm listening to music or playing a game, where the audio pretty much stutters with some frequency. Aside from those examples, said hiccups also happen when I"m watching videos on youtube

I've done searches on other places, and I've also tried out a few possible solutions (Including a safe mode test). As of now, I cannot tell if this problem is being caused an issue with the hard drive, memory spikes on the RAM, or a hard-to-detect virus.

Feel free to ask for further technical details, and perhaps screenshots as well, and I'll do my best to provide them.

Offline jraju

  • Hero Member
  • *****
  • Join Date: Feb 2013
  • Posts: 2316
  • Location: india
  • Karma: 17
    • View Profile
Re: laptop "hiccups"
« Reply #1 on: August 14, 2014, 11:54:30 PM »
Hi,

                  Increasing of audio default with more than 100% may be one of the reasons. There is also a possibility of some loose wire connection in the audio slot.
                  Try massaging the blank space next to the on switch, to the right, where the audio plane is located in the laptop. you may get rid of the problem. The audio disturbances is because of the line connection problem of audio. I once had it . i massaged it aound and got rid of this problem. The audio plane is too tiny in the laptop and opening and finding it would be a cumbersome procedure. Just massage the surface of audio gently without using force on the finger tips.
                  If the audio is totally absent, then it would be drivers problem. You could hear the sound. ok
The Bottom line is "Check your hardware first if it supports the task you try".

Offline scarsxp

  • Newbie
  • *
  • Join Date: Apr 2014
  • Posts: 49
  • Karma: 1
    • View Profile
Re: laptop "hiccups"
« Reply #2 on: August 14, 2014, 11:59:50 PM »
Alright, I told him to come here. I talk to this guy on skype. I did a couple of things with him.

Issue mainly was that spotifier (music streamer) was lagging like every 10 seconds. So I remoted in team viewer. I closed chrome.exe, since he had a lot of tabs open. And it seems to take up a lot of memory, even though he had memory free. So it should work right. But I closed it. He said the music didn't lag, after I closed chrome. Or since I team viewed in and he played a song.

Spotifier helper.exe was running like what 3 in the background. So I closed those programs down. In fact deleted the exe in the folder of the program. backed it up just in case. Disabled it in the registry. Seemed quite useless and annoying.

He was running two anti virus programs Avast and Microsoft security essentials. Both had live protection turned on. I figured he should just have only one.  So he choose Avast, and I uninstalled MSE. Then I configured some stuff in Avast, such as not scanning while the disk is running. Not sure what that was. Maybe that was causing the problem. Avast doesnt take much ram.

He also said Mpc.exe never had a problem when running music or videos. So maybe it's tied to that specific application. Anyways after doing some stuff, ending tasks.

I loaded up chrome. had about  20 tabs, and the lag seemed to go away on spotifier, we tried a youtube video. Lag went away. He hasn't tried a game yet.  It was using about 4 gb of ram out of 6 gb. But no lag with video streaming.

Did disk check by the way. That went okay. Tried to have him run SMART test, but that wasn't so easy since the program we used wasn't working right.  I might have him use a dos boot disk to make sure everything is okay. Checked event viewer, didn't see disk errors anyways. The program I tried was fjdtwin.exe from storage toshiba's website. His disk drive is : Toshiba MK7575GSX . So it's hard to find diagonstic tools on that.

Thought it could be over heated, the temps weren't too bad for a laptop.
http://puu.sh/aRYmZ/6eabb3204b.png
http://puu.sh/aRYlU/307a86a1ae.png
67C might be a little high. Is it?


One thing that concerns me is a program called

G Buster browser defense

I researched it, it could be a trojan or be a use. Lots of complaints about it. Tried to remove it, but moveonboot wouldn't load. But I did disable it in services.
Tried to kill it in task manager, and process explorer. But it renables. So it's probably something has to be done in safe mode to get rid of.


That's sort of it for now. It's running fine, he might want to run combofix. I tried to disable avast, but that probably needs to be done in safe mode. combofix maybe needed to run in safe mode. Combofix just warns about avast, possibly all I needed to do was disable it rather than ending the exe and it would have worked.

He did run spybotsearch and destroy and restarted. I think he ran a few others.


My main concern is chrome. It seems like it uses way more ram then firefox. Don't know what he is going to do with that. Even though he has enough ram freed up Is it necessary to use so much? I just don't know. It's annoying to figure out how much ram it's using. Because you have to actually total up the ram on each exe you are using per tab. And some are over 100mb of ram each or 80mb of ram. I guess that's how it's programmed

The main issue is spotify and youtube. And chrome.exe at least from what I can tell.

He thinks the problem might still occur. Is there any other advice that would be nice.

Obviously laptops aren't workhorses like desktop, but his is a gaming one. Even then I know it's not a workhorse compared to desktops.

Again he just wants this documented. And he hasn't fully cleansed his computer from bunch of stuff in the background.
Maybe he still has to run some stuff. Any advice is appreciated. I just don't care for chrome.exe. Any of you guys used it? Or have any advice. Perhaps he has to get rid of chrome plugins as well.
« Last Edit: August 15, 2014, 12:17:12 AM by scarsxp »

Offline jraju

  • Hero Member
  • *****
  • Join Date: Feb 2013
  • Posts: 2316
  • Location: india
  • Karma: 17
    • View Profile
Re: laptop "hiccups"
« Reply #3 on: August 15, 2014, 12:11:19 AM »
Hi,  Scaresxp
                       Chrome is compromised with some trojans easily. Firefox is the best browser, even though it uses chrome in the back ground. Firefox fixes everything, by alerts  and it consumes less mb.
                         Regarding malwares and trojan, i would not suggest spybot. It tooks much of resources from the start and it is not that much dependable program like combofix, aswmbr.
                         If the fault is with the application, then he has to reinstall the software for the application afresh.Running malware bytes would definitely get rid of those buster browsers. Combofix is the next alternative. Malware bytes threat scanner found almost all rootkits, trojan and what not in the computer safely.
                        But the problem is , i think , in the application software files.
The Bottom line is "Check your hardware first if it supports the task you try".

Offline scarsxp

  • Newbie
  • *
  • Join Date: Apr 2014
  • Posts: 49
  • Karma: 1
    • View Profile
Re: laptop "hiccups"
« Reply #4 on: August 15, 2014, 12:24:06 AM »
I don't really get that with spybot (it's a simple program). Because when he used it, it seemed totally different from mine. Like it was a live protection program. Mine just stays installed and doesn't run in the background. Very simple to use, not cpu tasking. But if it's not great at finding things. Then okay.

Yeah, I think he does have to get rid of chrome. This is getting ridiculous, he told me he used it because he liked a certain feature that you can sync all of his web page history with google + or profile or whatever it was called. I don't think the risk is worth the reward.

Yeah, I will have him run combofix and malwarebytes then. Or when he sees this he will run them.
« Last Edit: August 15, 2014, 12:33:02 AM by scarsxp »

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10173
  • Location: UK
  • Karma: 122
    • View Profile
Re: laptop "hiccups"
« Reply #5 on: August 15, 2014, 03:09:07 AM »
If this article applies to your friend, then it has been a requirement of their bank http://insanebits.blogspot.co.uk/2007/04/g-buster-browser-defense-analysis-and.html

If you feel it is causing a problem and you can get rid of it with the use of that article, you'll find that HitmanPro.Alert (which I use) will do the job and may not be so heavy. http://www.surfright.nl/en/alert

As for what may be using up the memory, Process Explorer with Virus Total included will show what is running and if anything is malicious.

http://technet.microsoft.com/en-gb/sysinternals/bb896653.aspx

If these options in it aren't auto running, click on Options and check Verify Image Signatures and hover over VirusTotal.com and check Check VirusTotal.com and anything with a serious value in red should be treated as suspect and Googling it for more info on it, would be advisable before killing it.

You may also want to check the paging file settings http://windows.microsoft.com/en-gb/windows/change-virtual-memory-size#1TC=windows-7

It's also possible there is a build up in the temp folder which could be causing lag, but not sure if this would cause an intermittent problem.

To check - go Start - type %temp% and press enter.

If there's a substantial amount then click on Organize - Select all - Organize - Delete and then empty the Recycle Bin.

Keeping the cache clear can also help which the free version of CCleaner will do for you http://www.piriform.com/ccleaner/download

It also has an intelligent registry cleaner and is the only one I would trust, but uncheck the box for ActiveX before running it.
« Last Edit: August 15, 2014, 03:28:37 AM by Boggin »

Offline scarsxp

  • Newbie
  • *
  • Join Date: Apr 2014
  • Posts: 49
  • Karma: 1
    • View Profile
Re: laptop "hiccups"
« Reply #6 on: August 15, 2014, 03:54:00 AM »
He found this in malwarebytes:

http://puu.sh/aTjP0/3fa6bbb42f.png

He says the problem is still occurring, but not when I viewed his computer in team viewer before everything was working fine for him surprisingly. So I'm kind of confused.

This was after I told him to shut down his computer for 30 mins. Needed a reboot anyways.

So this is what he told me later on:
[4:05:08 AM] anon: gonna check now
[4:05:19 AM] anon: yep still lags
[4:06:29 AM] *: every 5 seconds?
[4:06:49 AM] anon: every 5 to up to 1 min
[4:10:00 AM] anon: cpu usage is at around 3% atm
[4:10:04 AM] anon: with chrome closed
[4:10:21 AM] anon: but with spotify and vlc still running
[4:10:33 AM] *: now close spotify
[4:10:41 AM] *: and try vlc
[4:10:54 AM] *: are spotifier helper.exe running also?
[4:11:06 AM] anon: no
[4:14:12 AM] anon: and still a lag

I went to teamview to see the problem. He had chrome loaded for some reason. But anyways, before I could do anything my isp went down. That's were we left off.

Alright thanks for the link to hitmanpro.alert to remove buster browser. Because malwarebytes didn't detect it apparently.
No idea process explorer had that feature to work with virus total.

I might have him check on those other things you mentioned then later too. As well as combofix if he didn't already. He'll probably see the post also.

Maybe it was a certain process I closed in the background which is why I got it to work without lag. When i did it in teamviewer. My only theory.

But before I did close more unneeded processes, I wanted to see the problem for myself first. Only first thing I did was close all instances of chrome.exe down. Can't remember what I closed when I did the first test.  But that worked.

Thanks for the feedback so far.
« Last Edit: August 15, 2014, 04:12:54 AM by scarsxp »

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10173
  • Location: UK
  • Karma: 122
    • View Profile
Re: laptop "hiccups"
« Reply #7 on: August 15, 2014, 04:23:38 AM »
If there's a substantial amount in the temp folder i.e. GBs then it will be worth doing a defrag after emptying the Recycle Bin but it sounds as if it's one of the background processes - have you checked msconfig Startup items ?

You can disable them all to see if the lag goes and then enable just one at a time, checking after each until the lag returns to ID the Startup item.

I prefer AdwCleaner to get rid of PuPs as MBAM may/not pick them up and supposedly get rid of them for them just to return http://www.bleepingcomputer.com/download/adwcleaner/

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: laptop "hiccups"
« Reply #8 on: August 15, 2014, 11:32:20 AM »
I have had the same thing happen on my system before. It was when I was using VMware and every few minutes VMware was pushing memory to the page file, but it was doing it a way that caused everything the drive was doing to put things into the disk queue and because of that I would have video and music skip and the system not respond until it was done.

In vmware I disable the memory trimming which was causing the problem with the drive and it is fixed.

So I know this will have to do with the hard drive, and if the hard drive is under a heavy load or something is filling the disk queue then you will get that problem.

I would open up the resource monitor and watch the disk monitor and keep an eye out for what things are using the drive the most when it happens. You most likly have a program running in the back ground that is causing it OR the hard drive has bad sectors and when windows is reading or writing to that bad sector it is causing it as well.

Shane

Offline scarsxp

  • Newbie
  • *
  • Join Date: Apr 2014
  • Posts: 49
  • Karma: 1
    • View Profile
Re: laptop "hiccups"
« Reply #9 on: August 15, 2014, 05:04:55 PM »
I followed some suggestions here. But I wanted to follow Shane's suggestion. But Resource monitor is just a glitched out window on his computer. For some reason. It will just show title, file menu and that's it.  I close the program. Reload it, and it's the same thing.

I need another tool to monitor disk usage. I could have him try it in safe mode, although, but then I don't think we can do the test of him watching videos.


update: I enabled I/O writes in the task manager. And watched for it again. And once again he said it wasn't lagging. So I told him next time to have task manager enabled so if it does it again, he can screenshot the program that is doing it.

It sees when I'm watching him in teamviewer it doesnt do it.

I got rid of said suspicious skype updater or plugin crap as well. looked like a trojan.
SKYPEC2CPNRSVC.EXE
Did some cleaning up. We will see how things go.

Ran process explorer through virustotal.com, all of them said to be clean, and the ones that weren't said can't find file. I didn't run AdwCleaner, because virustotal found 3 things on it, and chrome said it was bad. Not sure if it's false positive but probably is. I ordered him to use combofix now that I got rid of his silly version of spybot. So spybot shouldn't bother combo fix anymore.

Not sure what the deal is with Resource monitor and why it's glitchy.

I did disk checker again, everything said it was fine with no bad sectors. But I still should run smart test.
« Last Edit: August 15, 2014, 06:07:08 PM by scarsxp »

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: laptop "hiccups"
« Reply #10 on: August 15, 2014, 06:40:46 PM »
Sounds like you did all the right steps. If the problem comes back then doing a clean boot with all the 3rd party stuff disabled from startup would be a good test as well.

Because if the problem happens with all the 3rd party programs not running then we can count those out as the problem. If doing a clean boot keeps it from happening then we know it is one of those programs.

There is a good chance that if it is memory related and there is a memory leak from a program and the page file comes under heavy use that it will take some time after the system has been started up to tell.

You could also have him install the free version of my CleanMem tool and that might help keep things under control as well.

Shane

Offline scarsxp

  • Newbie
  • *
  • Join Date: Apr 2014
  • Posts: 49
  • Karma: 1
    • View Profile
Re: laptop "hiccups"
« Reply #11 on: August 15, 2014, 07:19:14 PM »
I don't think this is normal at all. He has 800,000 on a tab on chrome.exe on a youtube video he says is lagging.
I watch the same video, and I'm at like 9,000 between 10,000 for the whole firefox.exe

http://puu.sh/aUmzs/89953c6d5b.png

I'm not too familiar on these numbers and how it works with the hard drive although. So I ask your opinion.

Maybe I'm monitoring the wrong thing when the lag occurs. Don't know. There is a lot of other columns in the processor page columns in task manger. Still want to monitor the Total bytes/sec in resource monitor. Seems more accurate for disk usage.
« Last Edit: August 15, 2014, 07:52:10 PM by scarsxp »

Offline scarsxp

  • Newbie
  • *
  • Join Date: Apr 2014
  • Posts: 49
  • Karma: 1
    • View Profile
Re: laptop "hiccups"
« Reply #12 on: August 15, 2014, 09:30:18 PM »
Quote
Because if the problem happens with all the 3rd party programs not running then we can count those out as the problem. If doing a clean boot keeps it from happening then we know it is one of those programs.

Okay did clean, boot. By disabling all 3rd party programs except microsoft. It's still doing it. Now what. It's a microsoft program doing it? Or is it a hardware issue with the laptop?

Also, I made sure he disabled chrome.exe before he did the test. He also says it happens in mpc.exe.

Going to have him make a video with his cell phone of what exactly this lag looks like when he is playing the video. I have never seen it when I team viewed in.



Also, he ran combofix finally and did that before we did the clean boot test. It did it's thing and showed a log.


http://tempsend.com/DE7D426610

Here is the video. By the way, I reset pagefile.sys and hiberfile.sys, basically virtually memory.
Installed a different audio driver.
team viewed in, watched a video on vlc, didn't lag for him. I told him to close team viewer
the video started lagging. What the heck?

question is why would it work in team viewer , but not work properly if team viewer is not being used. Why is it when I'm viewing it through team viewer it works?

Then I told him to disconnect wireless (he disconnected it through network and sharing) . And he played the video.
And he says its working without lag. Cant fricken believe it. Now how do I fix the problem. Now that I got it isolated to something with the internet enabled. Or internet related.

What to do next, maybe he should try a wifi spot some where to see if it lags there. To see if it's just his wireless connection. Or any internet connection.
« Last Edit: August 16, 2014, 01:03:21 AM by scarsxp »

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10173
  • Location: UK
  • Karma: 122
    • View Profile
Re: laptop "hiccups"
« Reply #13 on: August 16, 2014, 02:27:22 AM »
Not sure why Team Viewer should make a difference but have him do speed tests on wired and wireless and have him download inSSIDer to see if there are channel conflicts http://www.techspot.com/downloads/5936-inssider.html

Offline scarsxp

  • Newbie
  • *
  • Join Date: Apr 2014
  • Posts: 49
  • Karma: 1
    • View Profile
Re: laptop "hiccups"
« Reply #14 on: August 16, 2014, 02:49:02 AM »
Not sure either. But disabling his wireless seems to fix the issue. I asked him to do that a couple of times. Just to make sure that was it. It seems like that is what is reproducing the problem. The problem itself started happening 2 weeks ago when he got a new ISP (not too long after).

It could very well be a problem with some network drivers, network software, or anything network related installed too. That's another thing came into my mind as well, is his wireless internet connection secure?

So thanks for the program recommendation.
« Last Edit: August 16, 2014, 02:50:52 AM by scarsxp »

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10173
  • Location: UK
  • Karma: 122
    • View Profile
Re: laptop "hiccups"
« Reply #15 on: August 16, 2014, 05:37:50 AM »
Did an ISP router come with the change of ISP ?

The speed tests can be done at www.speedtest.net

Not sure if executing the following commands as an admin from the command prompt would help but have your friend give them a try anyway and report if either of the commands fail.

netsh wlan reset winsock catalog
netsh int ip reset resetlog.txt
exit

Now reboot.

Offline scarsxp

  • Newbie
  • *
  • Join Date: Apr 2014
  • Posts: 49
  • Karma: 1
    • View Profile
Re: laptop "hiccups"
« Reply #16 on: August 17, 2014, 01:09:03 AM »
Alright, I ran "inSSIDer" not sure what I was looking for. My wireless network diagnostic skills aren't that great since I never used one.
But his Wireless network has security: WPA2-Personal. On channel 6. Does that mean any other networks in the neighborhood can't have his channel and that means a confliction?

Anyways, I ran those two commands you told me to do. And rebooted. Still the same issue.

Then after that I updated his wireless network adapter driver (seemed outdated comparing versions in device manager to manufacturers). Then his Lan adapter network driver I updated directly through device manager.

Then I disabled TCP/IP V6. Then I did a restart

And no lag for him so far (playing music in vlc player, etc), even with the internet working. I'm keeping my fingers crossed that this has worked. Not sure what the problem was or what was fixed. But I hope it's fixed. This seems to be solved for now. But just to be sure. I'll just wait on it. And report in about it if there still is a problem. If you guys have any other useful information I have missed. Let me know.

This still baffles me on what the problem was. His own connection messing with his laptop with programs that don't require internet connection. Unless network activity going through his internet some how stalls or interferes with how his software and hardware runs.
« Last Edit: August 17, 2014, 01:24:06 AM by scarsxp »

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10173
  • Location: UK
  • Karma: 122
    • View Profile
Re: laptop "hiccups"
« Reply #17 on: August 17, 2014, 02:56:29 AM »
It's possible TCP/IPv6 could have been the cause but that would normally give a noticeable cannot connect/timed out error when the computer is attempting to connect to a website using IPv6 when the ISP doesn't support it and it's normally default unchecked in a router anyway.

It was probably the network drivers although I've never known them to cause intermittent lag - they normally work or they don't, but Windows is always a learning curve  :smiley:

As for inSSIDer - you can have other users co-sharing a channel or overlap, but as long as their signal strength isn't within 20 of yours then they won't cause any problems but they can occasionally spike down the signal strength when that channel is congested - whether that has been causing the lag or not...

Look for one that will give the best signal strength and Link Score and is least congested and is not within 20 of the nearest RSSI value.

Usually if you are getting problems when using wireless, then checking to see if they persist when wired will determine if the problem is wireless, router or ISP related.

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: laptop "hiccups"
« Reply #18 on: August 18, 2014, 01:41:09 PM »
Sounds like the wireless on the router isnt sending the data fast enough to him via wireless.

Shane