Author Topic: permissions have changed  (Read 8626 times)

0 Members and 1 Guest are viewing this topic.

Offline Cozmik

  • Newbie
  • *
  • Join Date: Aug 2014
  • Posts: 7
  • Karma: 0
    • View Profile
permissions have changed
« on: August 18, 2014, 03:32:02 pm »
I've just used this programme and ticked all when repairing but I must have ticked reset all permissions because now i cannot install anything as i don't have permission on my own computer. I am the only user and never had a problem before.
 Can anyone tell me how to get Admin permissions back please... Silverlight won't install until I fix this.
Thank you

Offline Shane

  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9281
  • Location: USA
  • Karma: 137
  • "Knowledge should be shared not hidden."
    • View Profile
Re: permissions have changed
« Reply #1 on: August 18, 2014, 03:42:42 pm »
My program actually sets admins and system to have full access on the files and registry keys. You should have full access as well. Did you go and check the permissions on some folders to see?

Shane

Offline Cozmik

  • Newbie
  • *
  • Join Date: Aug 2014
  • Posts: 7
  • Karma: 0
    • View Profile
Re: permissions have changed
« Reply #2 on: August 18, 2014, 03:54:12 pm »
Hi...it was the first time i'd used it and had the problem shortly thereafter so i have no idea what i did wrong. :*(
  No matter how many Fix-it's i use nothing sorts the problem out. It says the System Administrator has set policies to prevent this installation...but i have changed nothing.

I think Silverlight.msi is missing and i don't know how to put that back...or if that's even the answer.

Offline Shane

  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9281
  • Location: USA
  • Karma: 137
  • "Knowledge should be shared not hidden."
    • View Profile
Re: permissions have changed
« Reply #3 on: August 18, 2014, 03:57:22 pm »
Quote
It says the System Administrator has set policies to prevent this installation...but i have changed nothing.

That isnt a permissions error. That means that something has installed certain registry keys, such as policyes that are restricting you from doing things. A virus will do this a lot of times as well. Sometimes it could just be a simple error.

Do you have problems installing anything else or is it just silverlight?

Also found this, for people with the same error.

Quote
    Browse the registry to HKLM\Software\Policies\Microsoft\Windows\Installer
    Create: DisableMSI       Type: REG_DWORD  value = 0   (0 should allow you to install it was originally 1)
    Browse to HKEY_CLASSES_ROOT\Installer\Products\
    Search the list for the product that is causing the error.. delete the folder in the products folder…  this may also correct your error.

Shane

Offline Cozmik

  • Newbie
  • *
  • Join Date: Aug 2014
  • Posts: 7
  • Karma: 0
    • View Profile
Re: permissions have changed
« Reply #4 on: August 18, 2014, 04:22:14 pm »
  Create: DisableMSI       Type: REG_DWORD  value = 0   (0 should allow you to install it was originally 1)

I saw this earlier but didn't understand any of this so I left it Shane. Where do you create?

Offline Shane

  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9281
  • Location: USA
  • Karma: 137
  • "Knowledge should be shared not hidden."
    • View Profile
Re: permissions have changed
« Reply #5 on: August 18, 2014, 04:24:15 pm »
It tells you where to create it, open regedit and go to

HKey_Local_Machine\Software\Policies\Microsoft\Windows\Installer

You also didnt answer my other questions. :wink:

Shane

Offline Cozmik

  • Newbie
  • *
  • Join Date: Aug 2014
  • Posts: 7
  • Karma: 0
    • View Profile
Re: permissions have changed
« Reply #6 on: August 18, 2014, 04:30:39 pm »
Sorry, as far as i know it's only Silverlight...haven't tried anything else tonight.
I'm in the registry but a bit lost. I've clicked Installer and two things come up on the right hand side: Default and Logging, Default has (Value not se) and logging says voicewarmupx.

That's as far as i got. :*)

Offline Shane

  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9281
  • Location: USA
  • Karma: 137
  • "Knowledge should be shared not hidden."
    • View Profile
Re: permissions have changed
« Reply #7 on: August 18, 2014, 04:32:13 pm »
Let me know if you have trouble installing anything else. That will tell me if the problem is system wide or just with silverlight :wink:

Shane

Offline Cozmik

  • Newbie
  • *
  • Join Date: Aug 2014
  • Posts: 7
  • Karma: 0
    • View Profile
Re: permissions have changed
« Reply #8 on: August 18, 2014, 04:37:19 pm »
When i've changed the value to 0 should i reboo please?

Offline Shane

  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9281
  • Location: USA
  • Karma: 137
  • "Knowledge should be shared not hidden."
    • View Profile
Re: permissions have changed
« Reply #9 on: August 18, 2014, 04:38:11 pm »
Yes

Shane

Offline Cozmik

  • Newbie
  • *
  • Join Date: Aug 2014
  • Posts: 7
  • Karma: 0
    • View Profile
Re: permissions have changed
« Reply #10 on: August 18, 2014, 05:03:18 pm »
Thank you so much for your help Shane and patience...all is well now and it installed okay.

I've been trying to fix it for five days without success, you are a gem. :*)

I will sleep easy tonight and i'm guessing that this topic is now closed.
Thanks again.

Offline Shane

  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9281
  • Location: USA
  • Karma: 137
  • "Knowledge should be shared not hidden."
    • View Profile
Re: permissions have changed
« Reply #11 on: August 18, 2014, 05:04:23 pm »
Happy to help :-)

Locking thread.

Shane