Author Topic: Windows 8.1 Modern Apps crashing (not launching) and Windows Store error  (Read 3716 times)

0 Members and 1 Guest are viewing this topic.

Offline Wesley

  • Newbie
  • *
  • Join Date: Mar 2015
  • Posts: 2
  • Karma: 0
    • View Profile
Hi,

My OS is Windows 8.1 retail and updated.
I've had this laptop for almost 2 years, but about 6 months ago I first had the problem related here, except when I create another test user everything seems to work just fine. At the time I decided to ignore this problem since I didn't use any of those apps but last week I wanted to use photos/music/other apps from win store and everything was crashing. At first not even my 'modern PC Settings' would work, then I found this command and could change my pc settings once again:

Quote
powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\ImmersiveControlPanel\AppxManifest.xml

After running this command and concluding it did work for the settings app, I started 'playing around' with it and trying to register other apps such as Photos, Camera, FileManager and even the Win Store itself. Turns out it also did fix those apps, but I still can't install any modern apps from win store and there are a couple apps which couldn't be fixed after I ran this command using 'ProgramFiles\WindowsApps\*\AppxManifest.xml' as path.

I tried refreshing WinStore cache and I also ran your Windows Repair Tool (latest version available) as suggested but it didn't fix it.

Screenshots (my system language is Portuguese):





Please, any help?

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
I am going to be updating the repair windows 8 app store soon.

I was helping a user and found that I first did these 2 things on this page
http://www.marcelsmits.com/knowledge-base/windows-8-1-apps-and-store-not-working/

And then once those where done I ran the repair from my program and it got all the apps working again.

So try that, when you do the first 2 steps you will get access denied error, that is because you will need to take permissions for those files and registry keys, then after you remove those run my repair app store and see how it goes :-)

Shane