Author Topic: MS Office icons and shortcuts inop  (Read 4480 times)

0 Members and 1 Guest are viewing this topic.

Offline ddmoore66

  • Newbie
  • *
  • Join Date: Feb 2014
  • Posts: 20
  • Karma: 0
    • View Profile
MS Office icons and shortcuts inop
« on: August 09, 2015, 04:43:26 PM »
Shane,
My icons for MS Office 2013 no longer appear on my desktop. They now appear as a blank white page with the corner bent over. When you "double-click" on the icon, the program will start (ie. Excel) but the file itself will not open. However, If you start the program first then search for the file (even on the desktop) it will start normally.

Thank you sir!
David

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: MS Office icons and shortcuts inop
« Reply #1 on: August 10, 2015, 11:58:30 AM »
Open a cmd.exe window and then run these commands (1 at a time) These commands tell each office app to rewrite themselves to the registry and files, if that doesnt fix the icons then the icon cache on the system might be corrupt and my windows repair tool has a fix for that.

"C:\Program Files (x86)\Microsoft Office\Office15\winword.exe" /regserver
"C:\Program Files (x86)\Microsoft Office\Office15\excel.exe" /regserver
"C:\Program Files (x86)\Microsoft Office\Office15\powerpnt.exe" /regserver
"C:\Program Files (x86)\Microsoft Office\Office15\msaccess.exe" /regserver
"C:\Program Files (x86)\Microsoft Office\Office15\outlook.exe" /regserver

These commands are for the 32 bit version of office 2013 on a 64bit system. Let me know if they work, if they dont then we just need to change the commands to the other paths

"C:\Program Files\Microsoft Office\Office15\winword.exe" /regserver
"C:\Program Files\Microsoft Office\Office15\excel.exe" /regserver
"C:\Program Files\Microsoft Office\Office15\powerpnt.exe" /regserver
"C:\Program Files\Microsoft Office\Office15\msaccess.exe" /regserver
"C:\Program Files\Microsoft Office\Office15\outlook.exe" /regserver

Shane

Offline ddmoore66

  • Newbie
  • *
  • Join Date: Feb 2014
  • Posts: 20
  • Karma: 0
    • View Profile
Re: MS Office icons and shortcuts inop
« Reply #2 on: August 11, 2015, 03:00:12 PM »
Hey Shane,

I tried the commands. It seems my file locations are different than the ones you listed. Mine were, "c:\Program Files\Microsoft Office 15\Root\Office15\excel.exe" (then winword, outlook, etc). However, when I try running the commands nothing changes. I also ran the Windows All in One version of your Tweaking tool (v3.4.0). No bells or whistles or monsters with their heads spinning indicating a virus. So i'm just stumped.

Thanks Shane!

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: MS Office icons and shortcuts inop
« Reply #3 on: August 12, 2015, 06:30:25 AM »
It happens all the times with the icons, windows gets mixed up on what icon it is suppose to show and you get a white box instead :-)

Try this one, go to the control panel and then default programs. When it opens click on "Associate a file type"

When it opens you will have a very large list, instead of hunting down all the ones you need, lets just try a few and see if it works first.

So depending what file type is the word docs on your desktop you can do set .doc and .docx and for excel .xls and .xlsx and lets see if that does the trick.

Another trick that I have done on customers machines to get the icon to reset as well, go to one of the files, right click on it and go to "open with..." when you mouse over it, it will give you a list, click on default program at the bottom of that list.

When that list opens you can choose the default program for it and then put a check ont he box at the bottom to make it the default and hit ok. That will normally get explorer to write the icons again.

Shane

Offline ddmoore66

  • Newbie
  • *
  • Join Date: Feb 2014
  • Posts: 20
  • Karma: 0
    • View Profile
Re: MS Office icons and shortcuts inop
« Reply #4 on: August 12, 2015, 03:54:09 PM »
Still nothing Shane....

I tried both methods and the screen flashes but no changes are made. I could live without the icons, they are not as big of a concern as the shortcuts not working. Whether I double-click or right click and select open (or open with), the program itself opens but the file will not open unless I click open from inside the program.

David

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: MS Office icons and shortcuts inop
« Reply #5 on: August 17, 2015, 01:30:22 PM »
Sounds like the permissions are screwed up in the hkey_classes_root section of the registry.

I just updated my windows repair to v3.4.2 and redid the registry permissions. Grab it, have it do a registry backup and then just run the registry permissions (It is the first repair) and after it does that see if the changes will work.

Shane