Author Topic: Registry Backup 3.3 running forever, using 25% CPU  (Read 3109 times)

0 Members and 1 Guest are viewing this topic.

Offline TechGuy8

  • Newbie
  • *
  • Join Date: Nov 2014
  • Posts: 2
  • Karma: 0
    • View Profile
Registry Backup 3.3 running forever, using 25% CPU
« on: October 29, 2015, 04:39:21 PM »
I installed a week or two ago the then-current v3.3 of TC Registry Backup.
Checked the Task Scheduler and it seemed to be there.
And it has run regularly on computer startup. And created an apparently available set of reg backup data.
What is not good, is that it continues to run in the background, using 25% of CPU computer resources. I have rebooted the machine and watched and it does this every time, continueing to run up through 35 minutes after system reboot, until I manually Quit the Registry Backup program process.  I put in a '1 hour' force quit if still running option into the Task Scheduler, but it would be better of course if it would just end gracefully on its own.

ENVIRONMENT: Windows 7 Pro, SP1, 64-bit.  Dell Optiplex 3010, 4 GB RAM.

Ideas?   
I am planning to update Registry Backup to the most recent v3.3.1, but it does not indicate any fix to my particular situation.
Unless of course, it is totally normal and expected for Registry Backup to take 15 to 30 to 45 minutes (or more?) to actually make the backup of the registry files.

Thank you.

Offline Willy2

  • Hero Member
  • *****
  • Join Date: Oct 2011
  • Posts: 1136
  • Karma: 18
    • View Profile
Re: Registry Backup 3.3 running forever, using 25% CPU
« Reply #1 on: October 29, 2015, 05:24:03 PM »
Some thoughts popped up when I look at the pictures.

- Are there other processes running at the same time (think Task Scheduler) ? I see that Carbonite uses A LOT OF CPU as well.
- Is perhaps Carbonite using the "Volume Schadow Copy" Service as well, at the same time ? Perhaps you can delay Carbonite or Registry Backup more, in such a way that they don't run at the same time ?

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Registry Backup 3.3 running forever, using 25% CPU
« Reply #2 on: November 03, 2015, 08:51:45 PM »
Looks like the program is stuck in a loop.

The one loop it does when you start up is loop through the backup folder and add the backups to the drop down list in the restore tab.

So the loop is calling the findfilenext api to loop through the folders and then grab the info from each backup. Either something is messed up in one of the backups or there is a symbolic link in one of those folders that is pointing back to a parent and making an infinite loop (This should never happen unless some other program made the link)

So as a test try renaming the current backup folder and run the program, it should create a new one and then do a backup. See if it stops then. If so then we know it is one of the backups.

The other time I have seen this was when there was a file system error and after running chkdsk and the file system was repaired it worked fine as well.

Shane