Author Topic: Help w/Win 7 Pro 64 bit - it's as if Windows Update doesn't recognize itself  (Read 4130 times)

0 Members and 1 Guest are viewing this topic.

Offline goldengirl

  • Newbie
  • *
  • Join Date: Feb 2016
  • Posts: 3
  • Karma: 0
    • View Profile
Hi and thanks in advance for any assistance and advice! First off, let me start out by thanking Shane and anyone else that may have been involved in the all-in-one repair tool. The only thing that worked enough to let me connect to ask for help. I'm very grateful, and also very stupid.  :confused: I also apologize at the length of my comment as I read it now.

So it's largely my fault, at least. First mistake was setting my primary user profile as admin and then continuing to use that, rather than creating a simple user profile without system and hidden file access or change privileges. Hubris is a bitch, and also I was so eager to use this wonderful machine I couldn't be bothered to do the recommended actions, thinking I'd get to it later. I'm an idiot for all of this. Just need to say that upfront.

I'm just a critical care nurse and wanna be geek - after getting interested and involved with HIT disruption in healthcare - who knows just enough - and can exhaustively research  - to be dangerous and think I can fix it if I just read enough. On a personal note, I've been a nurse for a long time, and I have never seen something like this magnitude of change happen in medicine. It's got me reenergized and stoked again about healthcare as a profession, it's so exciting and my thirst for more knowledge is limitless. This is my new specialty: eventually we all become experts in our chosen field, and then are at risk of it becoming rote and boring. Though some would think you'd never tire of seeing - just as one example - the innovative ways people insert things into themselves....I digress.

But at least part of my nurse fatigue traces back to my interest in biochem resulting, ultimately, in losing many US renal patients I'd been working with via telemedicine - Katrina was responsible for that. When my LA, MS and - to a lesser extent - AL patients didn't turn up in another place or state for dialysis I knew they had died. Can't live without it.

I'd done pretty much all I could do. Was involved in research, purely right time and place (but also willing to do the hard work) while working at Northwestern, got me coauthor listing on some peer-reviewed journals as well. I also learned how to develop Access DBs, rudimentary use of SAS, proprietary analytics programs looking at data vs Milliman, LOS, admits/1000, days/1000, etc. I do realize that I'm like a current 10 year old kid playing around with stuff to figure it out. I am not an IT expert, not even at the basic ameteur level.

But IT is something I would have gone into if it had been as commonplace when I went to college. I can disappear down rabbit holes in pursuit of info and hours go by. I love it. And therein lies the problem. With this self-created problem, it's been a week of searching and asking.
I tell you all this, I guess, partly to show how much I love this stuff, and partly so there isn't some dumb blond impression -though I've been that too! I know how to operate -and how they work - all kinds of complex machines. So I sometimes overestimate my problem solving ability in other areas that I really like but don't know.  I was also trying to rely on just free stuff  :rolleyes:. It's hard to accept, sometimes, that even children - let alone pros in the field - can know and innately understand this stuff because they grew up with it. Please understand I have learned my lessons the hard way. But you can enumerate my errors yourself below:

This started when I researched the free protection programs when McAfee trial (already installed) ran out. Right before it did, I researched which programs were best, and first chose Avast. Then one day online I was sure something had intruded while shopping securely when a popup security warning came up saying I was compromised, and Avast hadn't picked it up.
So I did more reading, found some comparison tables, and chose the free version of AVG. I uninstalled Avast, installed AVG. THEN I started having memory problems, looked at files, event viewer, and logs, and saw AVG was causing the system to create these humongous files. In addition, virustotal said I had 2 that weren't picked up by AVG.
I was trying to remove the trial AVG antivirus because of that, and the dire warnings were making me paranoid and had already led me to do some very bad things. After uninstall there were MANY AVG files still left. Dumb me removed them after changing file permissions (and in the process learned not to EVER do that again!).

There were also logs replicating like aliens chewing up almost the entire memory on a brand new (well factory refurbished) Dell E6440 Latitude Win 7 Pro 64 bit laptop with 8Gb RAM, hybrid drive. I now think I understand that all this occurred because I changed the permissions, had at least vestiges of more than one AV program, etc.

So I researched them and found on MS that this was also common and it was ok to remove everything but the most recent because they were cumulative. Being overly cautious - I thought - I kept the first and the last just in case.

I did not do a backup or image, also bad. Right now, the internal Dell files have the factory image, and I also have the original disk that came with the laptop. But it doesn't have all the Win files from Update when it was working properly, and who knows what else, like drivers,  isn't on there. So that, and the original disk, are last resorts for me. And reading this forum, I understand others feel the same way.

But I've added lots of programs like Office 360, SP1 for 64 bit, and most importantly - the 3D Anthology  :wink: Most were purchased or free online so no backup disk. I had set restore points but that was AFTER the problems started. I don't know if I should set one now, when the whole Win Update and OS are still goofed up. I did do backups of docs/pics/faves/user profiles. Like internal update program and external MS do not recognize I have Win 7 Pro 64 onboard.

 Worse yet, in changing file permissions or removing files, TrustedInstaller disappeared from the users completely, so was unable to revert back (found a list of the default permissions and was laboriously going through them one by one until I realized I couldn't change back to TrustedInstaller because it was GONE from the list. Apparently THIS TOO is a common problem -albeit mostly caused by the end user - and has existed for at least the last 7 years. So am I wrong in thinking MS should have - at the very least by now - created some fix for that? Or at the very least a "Danger, Will Robinson!!" dialogue box to appear before doing something that isn't intuitive - removing any future possibility of restoring TrustedInstaller as the user and/or owner - when all you think you are doing is changing the user/owner??

Most VIP medical devices will let me know if I'm about to bolus someone with 10 times the Adenosine or Amiodarone that I intended. Or if my algebra is off that day such that I erroneously enter the wrong data into my dose/kg/min calcs, or try to turn off the central alarm on someone because I KNOW they keep having short runs of VT but it's clinically ok. Even IF it's ok, or has already been pharmaceutically addressed, I am unable to do so because of the life-threatening nature that data implies.

That's what a $ hundreds of billions worth company could and should do to prevent idiots like me from creating irreversible damage. Because it is sensible and logical. There isn't even a warning that this will also remove TrustedInstaller for good - something a logical person would not think occurs (it's a CHANGE, not a DELETION) - which I think is inexcusable and would have given me pause at the time. Add to that the fact that people have been reporting this issue since at least 7 came out, and I can begin to feel like they really don't give a shit about end user ease OR feedback.

And why isn't there a way for MS to keep records - isn't that the purpose of registering our purchase? - and then allow morons like me to just download the specific files we need to replace or restore? Clearly I'm not the software genius MS is, yet I and many others have thought of this, why don't they do it? There must be a way to guard against bootlegging and replication.

One more piece of info: My Dell backup/restore (separate from the Win one) that has the factory image has some support info about MS allowing only one restore Windows download, and advises to download to a thumb drive or other external media in order to be able to use it more than once. What I can't figure out is if that is a DIFFERENT option than doing the factory restore file or disk. Really what I want is the ability to replace the system kinds of files and retain my personal stuff without having to start over.

Since this is the only source/person/program that has given me any real help, improved my system such that I can actually use it to fix now. I was also in chat on my phone with Dell and MS to no avail, and they didn't seem to get it - that my system at that point wouldn't even connect with the internet to be able to download anything, and if it was, it didn't recognize it was missing anything, and when downloading (like Win 10) nothing executable resulting in a successful OS. They kept saying I could download files, then said download on phone thumb drive, which I don't have.Hours chewed up with them to no avail.
And that my system would tell the download source that all was well when it wasn't.

I'd been trying to resolve this for the last week, trying every possible fix (including MS Support, one of the places I learned this was a common problem with AVG).

Finally found this repair tool all-in-one (bless you!) which seemed to solve most of the problems where nothing was working except in safe mode. Including audio drivers etc. I'm assuming - as I write this in Win 7 OS - that the same is true of some Win drivers.

But now Win Update still doesn't recognize it's running on a Win 7 Pro system and keeps saying all files are UTD. But when I look at the Windows update history, there is not a single file. I have a free convert to 10 so as a last choice I thought I would just do that. But that just looks like it's downloading files, then stops. No Win 10 files will install, at least that lead to changing OS to 10. I've tried 3 times.

So I'm stuck. The repair program on here got the firewall working and many things fixed, which is more than I can say for a week's worth of research and attempts. Does anyone know what I can do to get the system to recognize itself (and also when communicating with MS)? I know I can do a disk reinstall but don't want to lose my data, plus on blogs I've read that this sometimes doesn't work or makes the system FUBAR. Can anyone help me?

The repair program fixed lots, but said Win was ok. It also recommended CHKDSK, with R and F, which I did several times. The first time I stopped it after ~ 3-4 hours and stuck at 33%. THEN I read it can take days (sense my pattern here?). So I redid it, determined to stick it out however long. The next 2 times it ran and returned to the Win login screen in under an hour. Not fixed. Did I damage that by stopping the first time?

Also, one last question: after this repair program, I now have an additional user profile called (unknown user) but that seems to have the same #s (are they security #s to indicate from what source? ) that were present on an earlier version. Am I right?

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10172
  • Location: UK
  • Karma: 122
    • View Profile
Basically - Too much info.

This makes it very difficult to understand the problem other than you uninstalled TrustedInstaller ?

Read through this article and then download the one for Windows Module Installer - which is TrustedInstaller then re-write your thread with what you had previously done and if having reinstalled WMI has made any difference.

The left column are all active links.

http://www.sevenforums.com/tutorials/236709-services-restore-default-services-windows-7-a.html

Offline goldengirl

  • Newbie
  • *
  • Join Date: Feb 2016
  • Posts: 3
  • Karma: 0
    • View Profile
Thanks for the quick response, and yeah, TMI.
Sorry.
Am I to still do this if the repair program says it was already fixed? I attach the original repair logs, which list the Win Installer as repaired on the first run. I did run it 3 times and can attach any of those files if needed.
Please just let me know if I should still do that given the indicated repair with your tool.

Thanks!

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10172
  • Location: UK
  • Karma: 122
    • View Profile
It's Shane's program and I'll have to ask him about those error logs.

The WMI repair in the program is for the Windows Management Instrumentation service which is a different service to the Windows Modules Installer service.

Go Start - type services.msc and press enter then scroll down to see if the Windows Modules Installer is listed.

It should be showing as Manual and may or not be showing as Started.

If it is listed and doesn't show as Started, then click on it then on Start in the upper left pane to see if it will or you get any error messages.

If it isn't as it should be then download it as instructed in the article I've posted.

Offline Julian

  • "Professional Googler"
  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jun 2015
  • Posts: 1325
  • Location: USA, New Mexico
  • Karma: 38
    • View Profile
okay first i need you to open cmd and type in chkdsk /f c:
you will get this message:
Quote
The type of the file system is NTFS.
Cannot lock current drive.

Chkdsk cannot run because the volume is in use by another
process.  Would you like to schedule this volume to be
checked the next time the system restarts? (Y/N)
Press y then press enter reboot your computer and let it run after that runs and you log back in your computer I want you to open up event viewer type "event viewer" in the start menu i posted a picture I need you to copy and paste that info onto this thread.

now so your recent updates will show blank after you run the windows repair program here are some snapshots when you open up programs and features.
Julian