Author Topic: Windows 7 Ultimate - Netgear A6210 Latency Problem  (Read 8287 times)

0 Members and 1 Guest are viewing this topic.

Offline FreeCat

  • Sr. Member
  • ****
  • Join Date: Apr 2013
  • Posts: 277
  • Karma: 0
    • View Profile
Windows 7 Ultimate - Netgear A6210 Latency Problem
« on: August 25, 2016, 07:58:10 am »
Howdy -
I have a latency problem and the event viewer shows me that I have to disable the LSO (large Send Offload) on my Netgear A6210.  Maybe there are more things.  Many errors in the event viewer. Some are related to not being able to start a priner device; I have not printers directly attached to this PC --- only a network printer.  Should I deleted all those printers that are there?  (Where did they come from anyway).  But, i want to start with disabling LSO as from what I read that could be the cause.  Thanks, in advance, for your help.

Here are some of the errors from the event viewer:

Your computer was not assigned an address from the network (by the DHCP Server) for the Network Card with network address 0x00FFB7127985.  The following error occurred: 0x79. Your computer will continue to try and obtain an address on its own from the network address (DHCP) server.

Service cannot be started. System.NullReferenceException: Object reference not set to an instance of an object.
   at ​​‬‬​​‍​​‏‪‌‪‎‏​‬‏‫.‍‏‎‪​‬‌‫‏​‫‏‪‎​‫‫​‫(Int32 )
   at ​​‬‬​​‍​​‏‪‌‪‎‏​‬‏‫.‍‍​​​‫‫​‎‎‬‪​‍‍‍‌​‏‫‍‎‫‪‍(String[] )
   at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)

The server {9E175B6D-F52A-11D8-B9A5-505054503030} did not register with DCOM within the required timeout.

The description for Event ID 104 from source SRService cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

Printer PaperPort Color Image failed to initialize because a suitable PaperPort Color Printer Driver driver could not be found. The new printer settings that you specified have not taken effect. Install or reinstall the printer driver. You might need to contact the vendor for an updated driver.

Event provider NcsWmiEventProv attempted to register query "SELECT * FROM IANet_802dot3TeamEvent" whose target class "IANet_802dot3TeamEvent" in //./root/CIMV2 namespace does not exist. The query will be ignored.


The SeaPort service terminated unexpectedly.  It has done this 1 time(s). ,=== I DO NOT KNOW WHAT A SEAPORT IS.


The Windows Search service terminated unexpectedly.  It has done this 20 time(s).


FWIW, there are some warnings also.  Like: Certificate for local system with Thumbprint b2 52 53 79 9b 63 0d 22 d2 dc 42 53 c4 30 16 da 99 91 13 7a is about to expire or already expired  <=== ID NOT NOT CARE ABOUT THIS THUMBPRINTS STUFF.

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: Windows 7 Ultimate - Netgear A6210 Latency Problem
« Reply #1 on: August 26, 2016, 06:58:30 am »
I've never used a Netgear so that LSO may be peculiar to that.

I was getting DHCP-Client Event ID 1002 with a similar message to yours and I suspected it to be a router fault where DHCP wasn't assigning IP addresses as it should.

I would get this event ID on three different machines after booting up.

Generally you can ignore it but in Device Manager/View/Show hidden devices - expand Network adapters where you'll probably see incremented MS ISATAP adapters.

You can right click on the incremented ones and select Delete, although they'll probably just be recreated when Windows is initially unable to make a connection - but they can mount up if not kept an eye on.

My router was an ISP supplied one so not sure if a firmware update would have solved that, but there may be a firmware update available for your Netgear model - that's usually the first step if you think a router isn't performing as it should, but save the current config before upgrading so that you can revert if an upgrade is problematic.

I also get a Printer error when my printer isn't switched on before I boot the laptop - see if you still get it with your printer switched on before the computer.

As for the rest, run a command prompt as an administrator and enter sfc /scannow to see what that reports.

If it reports there are files that it cannot repair, then download SFCFix.exe from http://www.majorgeeks.com/files/details/sfcfix.html

This will produce its own report and may fix what sfc /scannow was unable to.

If it reports it is also unable to fix then copy & paste and post its report.

To determine if you are using the correct MTU setting, download TCP Optimizer - select Save then right click on it in your Downloads folder and select Run as administrator.

http://www.speedguide.net/downloads.php

Both the router and computer MTU setting should be set to 1500 before you start.

To check your computer, run a command prompt as an administrator and enter -

netsh interface ipv4 show interfaces

This will give an Idx No. for each interface.

1500 is usually the computer's default setting, but should you need to change it to what Optimizer recommends then enter this command for your wireless and Ethernet.

netsh interface ipv4 set subinterface [Idx No.] mtu=[recommended] store=persistent (without the brackets)

e.g. For my wireless interface I would enter netsh interface ipv4 set subinterface 5 mtu=1492 store=persistent as 1492 has previously been given for my connection and 5 is the Idx No. for that interface.

Then redo the netsh show interfaces cmd to confirm.


Offline FreeCat

  • Sr. Member
  • ****
  • Join Date: Apr 2013
  • Posts: 277
  • Karma: 0
    • View Profile
Re: Windows 7 Ultimate - Netgear A6210 Latency Problem
« Reply #2 on: August 27, 2016, 11:13:06 am »
Thanks for all this information, Boggin.  Years ago I wrote some kernels for Forth, etc. and did sysgens for IBM 360/370.  But, I am not sure that I can competently implement all your suggestions.  I need this machine for work and can not mess it up.  Do you know anyone (or can you) who I can can pay to implement/investigate your comments.