Author Topic: Windows can't download anything from Microsoft servers (updates, store, etc.)  (Read 1108 times)

0 Members and 1 Guest are viewing this topic.

Offline JainJude

  • Newbie
  • *
  • Join Date: Jul 2019
  • Posts: 1
  • Karma: 0
    • View Profile
Version 1903, build 18362.239.

Recently made a fresh install of my windows (full reformat) due to new hardware. Immediately have noticed that nothing seems to be able to be downloaded from either required updates which stay at 0% forever and now the store, which no matter what app will always give me a straight "Downloading..." and nothing else to do with the progress.

So far I've tried almost every method I've found online, from the multitude of powershell tricks, recreating SoftwareDistribution and catroot2. Have attempted to rollback to 1809 without luck as well as fully resetting and reinstalling the microsoft store for that issue. Have messed with services for the update but nothing there.

At this point I've figured out the updates, and have manually downloaded most and hidden one. Yet no matter what I've tried no progress is made in any downloads by Windows.

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 9964
  • Location: UK
  • Karma: 122
    • View Profile
Can you open Windows/File Explorer - right click on This PC and select Properties.

This will tell you if Win 10 is activated.

If it is then go Start - click on the Settings icon - Update & Security - Troubleshoot and click on the one for Windows Update.

If it isn't, there's also an option for Activation.

I assume your clock is showing the correct date and time ?