Author Topic: Follow-up of translation issue since WR installer 4.11.x  (Read 3071 times)

0 Members and 1 Guest are viewing this topic.

Offline neroilo

  • Full Member
  • ***
  • Join Date: Jun 2012
  • Posts: 183
  • Karma: 7
    • View Profile
Follow-up of translation issue since WR installer 4.11.x
« on: July 29, 2021, 06:47:59 AM »
I just wanted to report that the following issue wasn't fixed in v4.11.4 and v4.11.5:
https://www.tweaking.com/forums/index.php/topic,6773.0.html
« Last Edit: November 27, 2021, 04:33:23 PM by neroilo »

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #1 on: July 29, 2021, 01:29:46 PM »
I passed a link to your thread to Shane but didn't get a reply.

You can still select your language after installation - perhaps Shane considers that is all that is necessary.
Tom.

Offline neroilo

  • Full Member
  • ***
  • Join Date: Jun 2012
  • Posts: 183
  • Karma: 7
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #2 on: July 30, 2021, 11:28:17 AM »
I passed a link to your thread to Shane but didn't get a reply.

You can still select your language after installation - perhaps Shane considers that is all that is necessary.

The problem is that the installer is always forced in my italian language, no matter if I set english language after installation.
It could be annoying for other users that don't know what to do with those checkboxes with labels set as Opzione1 and Opzione2.

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #3 on: July 30, 2021, 01:58:52 PM »
I haven't seen Opzione1 and Opzione2.

Mine defaults to English as I'm in the UK but I changed the language to Italian and it immediately changed to that language and stayed there.

Have you tried reinstalling the program ?
Tom.

Offline neroilo

  • Full Member
  • ***
  • Join Date: Jun 2012
  • Posts: 183
  • Karma: 7
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #4 on: July 30, 2021, 02:08:08 PM »
I haven't seen Opzione1 and Opzione2.

Mine defaults to English as I'm in the UK but I changed the language to Italian and it immediately changed to that language and stayed there.

Have you tried reinstalling the program ?

I tried uninstalling and reinstalling and it didn't work.

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #5 on: July 30, 2021, 02:39:11 PM »
I'll email Shane again with a link to this thread.
Tom.

Offline neroilo

  • Full Member
  • ***
  • Join Date: Jun 2012
  • Posts: 183
  • Karma: 7
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #6 on: August 01, 2021, 05:08:38 AM »
I'll email Shane again with a link to this thread.

Ok, in case you get a reply please let me know here.

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #7 on: August 01, 2021, 02:41:26 PM »
I have asked Shane to reply in the thread but not sure when the reply will come as I also linked another thread for him to look at.

Hopefully he will be looking at both but if I don't see or get a reply in a week, I'll email him again.

He is very busy as he also has a computer repair business to run.
Tom.

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #8 on: August 09, 2021, 01:37:06 AM »
I've sent another email sent this morning, but as I'm 8hrs ahead of him, not sure if or when he picks it up.
Tom.

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #9 on: August 10, 2021, 08:39:25 AM »
Shane's working on it.
Tom.

Offline neroilo

  • Full Member
  • ***
  • Join Date: Jun 2012
  • Posts: 183
  • Karma: 7
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #10 on: August 12, 2021, 01:22:31 PM »
I've tested 4.11.6 released today, and I can confirm the bug on this version too.

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #11 on: August 12, 2021, 01:36:05 PM »
This is Shane's reply -

 I don?t seem to have anything to check and autoset the language, but the setting for it is in the settings.ini file in the program folder, also he should be able to simply change it on the main window of the program.

 I've emailed Shane again explaining that it's auto resetting back from English to Italian.
Tom.

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #12 on: August 12, 2021, 01:46:00 PM »
This is Shane's reply to my last email - can you post that pic ?

That is extremely odd, unless there is a problem with how the program is trying to set the combo box. But I don't see why it could. But something is happening for it to be auto set like that. As you seen from the code I sent it sets the drop down via text and not by index. I wonder if his system his changing the way the text is being shown, that would explain it.
Can you get screenshots from him showing the drop down box open so we can see how the text looks?
Tom.

Offline neroilo

  • Full Member
  • ***
  • Join Date: Jun 2012
  • Posts: 183
  • Karma: 7
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #13 on: August 13, 2021, 04:11:34 AM »
This is Shane's reply to my last email - can you post that pic ?

That is extremely odd, unless there is a problem with how the program is trying to set the combo box. But I don't see why it could. But something is happening for it to be auto set like that. As you seen from the code I sent it sets the drop down via text and not by index. I wonder if his system his changing the way the text is being shown, that would explain it.
Can you get screenshots from him showing the drop down box open so we can see how the text looks?

Here below I attached the screenshot of drop-down box open in the main program, my W10 custom scaling settings in the second attachment and the italian translation issue in the third attachment.
My screen resolution is 2560x1440.

Do you think there is a relation with the missing italian options descriptions in the third attachment?
« Last Edit: August 13, 2021, 05:14:51 AM by neroilo »

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #14 on: August 13, 2021, 07:20:28 AM »
I've emailed Shane with a link to your thread.
Tom.

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #15 on: August 13, 2021, 10:10:11 AM »
Shane has suggested that you try the portable version for comparison.
Tom.

Offline neroilo

  • Full Member
  • ***
  • Join Date: Jun 2012
  • Posts: 183
  • Karma: 7
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #16 on: August 13, 2021, 10:26:11 AM »
Shane has suggested that you try the portable version for comparison.

Here below I attached the screenshot of drop-down box open in the portable program:
« Last Edit: August 13, 2021, 02:26:20 PM by neroilo »

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #17 on: August 13, 2021, 10:35:10 AM »
Does that also auto reset to Italian ?
Tom.

Offline neroilo

  • Full Member
  • ***
  • Join Date: Jun 2012
  • Posts: 183
  • Karma: 7
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #18 on: August 13, 2021, 02:07:25 PM »
Does that also auto reset to Italian ?

Nope, the portable version looks fine. It was english at first and I changed it to italian.
I don't think it has something to do with the installer issue.

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #19 on: August 13, 2021, 03:15:36 PM »
I'll pass that onto Shane.

That may help him pinpoint what is happening in your case.

WR is working fine for me, so if Shane is unable to replicate it on his machine then it may be very difficult for him to resolve if it is peculiar to your machine.
Tom.

Offline neroilo

  • Full Member
  • ***
  • Join Date: Jun 2012
  • Posts: 183
  • Karma: 7
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #20 on: August 16, 2021, 03:08:48 AM »
I'll pass that onto Shane.

That may help him pinpoint what is happening in your case.

WR is working fine for me, so if Shane is unable to replicate it on his machine then it may be very difficult for him to resolve if it is peculiar to your machine.

In addition to my real Windows 10 machine, I was able to replicate it on a Windows 10 vm with these language settings set in the first Windows setup.

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #21 on: August 16, 2021, 06:10:44 AM »
I haven't had anything back from Shane yet.

I'll give him a bump in a few days time.
Tom.

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #22 on: August 18, 2021, 12:45:30 PM »
I was trying to send Shane a bump email but my email seems to be playing up.

I'll try again in the morning.
Tom.

Online Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10013
  • Location: UK
  • Karma: 122
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #23 on: August 19, 2021, 01:57:46 AM »
email sent and replied to.

Shane is having problems with this as he's unable to replicate it.

Should the problem be with your Windows can you open a Command Prompt (Admin) or Powershell (Admin) and run these cmds - letting me know what they report.

dism /online /cleanup-image /restorehealth

sfc /scannow

Enter exit to close the cmd wind and try WR again.
Tom.

Offline neroilo

  • Full Member
  • ***
  • Join Date: Jun 2012
  • Posts: 183
  • Karma: 7
    • View Profile
Re: Follow-up of translation issue in WR installer 4.11.x
« Reply #24 on: August 19, 2021, 06:03:42 AM »
email sent and replied to.

Shane is having problems with this as he's unable to replicate it.

Should the problem be with your Windows can you open a Command Prompt (Admin) or Powershell (Admin) and run these cmds - letting me know what they report.

dism /online /cleanup-image /restorehealth

sfc /scannow

Enter exit to close the cmd wind and try WR again.

The output of those commands reported that no issue was found and WR has still the same issue.
Is it ok if I send you a PM with a download link containing the VM with the WR installer issue?
« Last Edit: August 19, 2021, 06:12:28 AM by neroilo »