Author Topic: USB device not being seen by windows  (Read 9824 times)

0 Members and 1 Guest are viewing this topic.

Offline Michael22

  • Newbie
  • *
  • Join Date: Aug 2014
  • Posts: 23
  • Karma: 0
    • View Profile
USB device not being seen by windows
« on: May 24, 2022, 07:54:55 am »

I am running WIN 10 Hone 21H2

Here is my problem

I have been using a program to download data from a device for years without any problem. I would usually connect it to my PC into a USB port and then the program would download the necessary data to analyze. I only used this program from spring to fall. So, I supposed that following some updates from windows this happen.

Lately, when I connect that device I get a window saying that I need to connect the device to my PC to a port between 1 and 64 and they explain what to do and furthermore ask me to download a specific Silicon Lab driver which by the way is already installed on my machine nothing happens even though I do that.

So I have done these tests:

1) I have used another USB cable. (nothing)
2) I have tried other USB ports on my PC, (same thing)
3) I have tried it on someone else PC  (It works fine)
4) I have uninstalled the program and reinstalled it,  (nothing has changed)
5) I have uninstalled the USB driver and reinstalled it (I get a message that the device has not migrated)
6) I have run Tweaking Pro (Same thing nothing has changed)
7) In device manager when I try to see my port even when (shown hidden devices is on), I do not see any port! (Com & LPT)
8) I have tried to install ports since they were not showing.
9) Now I have a yellow triangle next to port com 3 , if I uninstalled it windows does not reinstall it

So, what is the problem with my PC, can you help, please?

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: USB device not being seen by windows
« Reply #1 on: May 24, 2022, 08:52:37 am »
Sometimes power shutting the machine down by pressing and holding down the power button for about 30secs and then a restart can resolve anomalous problems.

If that doesn't work then open a Command Prompt (Admin) and enter these cmds -

dism /online /cleanup-image /restorehealth

sfc /scannow

Enter exit to close the cmd window and see if it now works.