Author Topic: Task Scheduler Issue. MMC Cannot Create Snap In.  (Read 9669 times)

0 Members and 1 Guest are viewing this topic.

Offline pjpw2320

  • Newbie
  • *
  • Join Date: Apr 2015
  • Posts: 1
  • Karma: 1
    • View Profile
Task Scheduler Issue. MMC Cannot Create Snap In.
« on: April 05, 2015, 07:41:05 pm »
This is not a request for help as such. I just wanted to post some information here which may be helpful to others experiencing an MMC issue. I have been using Shane's ClearMem utility for almost a year now and have been very impressed with it. Recently I had cause to re-check the Task Scheduler settings for it as it did not seem to be doing an automatic clean even though I could do a manual clean at any time with no problem. Other tasks I had in the Scheduler were working ok.

I then found that I could not open Task Scheduler. It would return the following error message:
"Task scheduler mmc cannot create the snap in. The snap in may not have been installed correctly." Upon further investigation I found that I received the same error message when I tried to open Event Viewer and Windows Firewall With Advanced Security, just with a different CLSID in each case. No other Computer Management programs appeared to be affected.

My system is a HP Laptop as follows:

CPU: 1500MHz AMD A6-3420M
GPU: 512MB ATI AMD Radeon HD 6520G (HP)
HDD: 465GB Hitachi HTS547550A9E384 SATA Disk Device (SATA)
Windows 7 Home Premium 64-bit SP1

Very much at the lower end of the spectrum!

Searching online gave me various suggestions to try to fix the problem, from first running SFC to downloading a utility I found called Fix My Task Scheduler, or editing or renaming .NET machine config files or MMC config files, or various other .NET related fixes including uninstalling .NET altogether, and even to doing a Windows 7 Repair Install as per

In my case:
SFC returned no errors.
Fix My Task Scheduler said it found and fixed 7 problems but I still got the same error message on trying to open Task Scheduler.
There was no mmc.exe.config file in my system 32 folder.
An instruction I found in relation to the machine.config file in the V2.0.50727 sub folder of my .NET installation not having an end tag for the <DbProviderFactories> was unclear so I left that alone.
All suggestions I found online either did not work or I was reluctant to try.

I decided to uninstall .NET 4.5 which was the only .NET installation showing in my installed programs, even though I had many uninstalled windows updates for .NET 3.5 and my .NET installation includes sub folders for V2.0.50727, V3.0, V3.5 and V4.030319. I had read online some time ago that these are still required even for a later .NET installation. I figured that at worst all I would need to do would be to re-install .NET 4.5 if a program I happened to be using called for it. So first step completed, .NET 4.5 uninstalled. Still no luck accessing Task Scheduler then even.

I also knew I had let my system get out of date in terms of Windows updates so I decided to bite the bullet and go there next. I set my computer to download and install updates overnight.

Next morning it still had 41 updates to go out of 160 total! It appeared to be not so much stuck but sitting on update number 119 for quite some time. This was the core XML SP2 update for my Windows 7 so I figured this was probably going to take a while. As I needed to use my computer I decided to stop the update and shut down my system and restart it, which took a while but eventually it fired up and loaded everything as normal.

Upon checking Task Scheduler, lo and behold, it opened! As did Event Viewer and Windows Firewall With Advanced Security. I was back in business! I love it when a plan comes together!! And nothing I found online in relation to this issue asked if Windows Updates were all installed!

Will now resume my Windows Updates!

Also, I want to give Shane a big rap for his site and the windows programs and utilities he offers for free or for a small price, and his readiness and willingness to step up and proactively help users with their PC problems, even to the extent of remoting in to users' PCs. Great work mate.

Just my two cents worth for the day.
« Last Edit: April 07, 2015, 07:14:42 pm by pjpw2320 »