Author Topic: Services reset to default in newest version of Windows Repair All In One  (Read 10412 times)

0 Members and 1 Guest are viewing this topic.

Offline Michael

  • Newbie
  • *
  • Join Date: Nov 2011
  • Posts: 11
  • Karma: 1
    • View Profile
First off Shane, THANK YOU! Your hard work is very much appreciated and I've never had any problems...until now. I have an ASUS laptop running Win7 Pro., 8gb ram, 1.5gb Nvidia GeForce GTX 460M and 1tb hard drive. I installed the latest version of Windows Repair All in One and ran thru all the steps. After doing the repairs my wifi was hosed. I reinstalled the drivers and ran thru all steps again but this time when I did the Repair step I deselected all but the Services reset to default step. Again with the wifi problem. (It's on me that I've chosen to turn off System Restore). While I have not run thru all the repairs with the exception of resetting the hosts file AND services reset to default (will do this soon to see if I can isolate if it is this that is causing issue) I've been using your software since you first started this site and have never encountered any problems. So, by the process of elimination I tend to think the services reset might be doing something to the wifi driver(s). No, this is not a critical review, I will continue to use what you make. You're very good. Just wanted to give you a heads-up.
Keep up the great work Shane.  :smiley:

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Services reset to default in newest version of Windows Repair All In One
« Reply #1 on: November 07, 2011, 04:12:46 PM »
See if your wlan service is running :wink:

The wlan service is set to manual
Wlansvc = demand

Perhaps it needs to be auto?

Check that and let me know.

Shane

Offline Michael

  • Newbie
  • *
  • Join Date: Nov 2011
  • Posts: 11
  • Karma: 1
    • View Profile
Re: Services reset to default in newest version of Windows Repair All In One
« Reply #2 on: November 07, 2011, 04:20:45 PM »
Thanks Shane. It is set to auto now and will run thru all the repairs again, including the services reset, and check it again. Will let you know what I find.

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Services reset to default in newest version of Windows Repair All In One
« Reply #3 on: November 07, 2011, 04:22:06 PM »
What I mean is, the repair will put it to manual.

If the wireless isn't starting with manual then that's the problem and I just need to change it to auto :-)

Let me know.

I am testing on my laptop right now as well. :wink:

Shane

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Services reset to default in newest version of Windows Repair All In One
« Reply #4 on: November 07, 2011, 04:37:45 PM »
blackvipers site lists the wlan services in windows 7 (The wireless service) as set to manual.
But when I set my wife's to manual and rebooted the service doesn't start. It has to be to set to auto.

I will put out v1.5.1 in the next 15 min to fix this :-)

Thanks for the heads up!

Shane

Offline Michael

  • Newbie
  • *
  • Join Date: Nov 2011
  • Posts: 11
  • Karma: 1
    • View Profile
Re: Services reset to default in newest version of Windows Repair All In One
« Reply #5 on: November 07, 2011, 04:42:43 PM »
You're more then welcome, glad I could help.

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Services reset to default in newest version of Windows Repair All In One
« Reply #6 on: November 07, 2011, 04:48:08 PM »
New version is out :-)

Shane

Offline Michael

  • Newbie
  • *
  • Join Date: Nov 2011
  • Posts: 11
  • Karma: 1
    • View Profile
Re: Services reset to default in newest version of Windows Repair All In One
« Reply #7 on: November 07, 2011, 04:49:19 PM »
Damn you're fast!! Thanks!

Offline vika6

  • Newbie
  • *
  • Join Date: Dec 2011
  • Posts: 1
  • Karma: 0
    • View Profile
Re: Services reset to default in newest version of Windows Repair All In One
« Reply #8 on: December 13, 2011, 02:57:02 PM »
The same problem is with WwanSvc -> after running Windows Repair All in One I lost my Mobile Broadband internet connection. Run diagnostic tests and learned WwanSvc didn`t start with Windows (was set to manual). Problem was solved when this setting was changed to auto.   :smiley:

BTW  Thanks Shane for your very helpful program ! 
With it I resolved my big problem with external disks. They couldn`t be seen in Windows Explorer (system refused to assign drive letters). Little program "Auto Assign Drive Letters" repaired it in 2 minutes only !!   :cheesy:

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Services reset to default in newest version of Windows Repair All In One
« Reply #9 on: December 13, 2011, 03:01:06 PM »
I see, on mine it is manual.

Quote
This service manages mobile broadband (GSM & CDMA) data card/embedded module adapters and connections by auto-configuring the networks. It is strongly recommended that this service be kept running for best user experience of mobile broadband devices.

I think the best thing to do with this one is remove the service from the repair. The service isnt needed for normal windows. Either that or I see if there is any problem having it set to auto by default on a system that doesnt have mobile broadband :wink:

Time to test.

Shane

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Services reset to default in newest version of Windows Repair All In One
« Reply #10 on: December 13, 2011, 07:27:23 PM »
I decided to just remove it from the repair :-)

Not to many people use it, so I prefer not to have another service running that isnt needed and I dont want it not working for people who need it. SO the best thing is to just skip it in the repair :-)

SO I will be removing
sc config WwanSvc start= demand

from the repair.

Thanks for letting me know!

Shane