Author Topic: Problem with Registry Backup v3.2.3 on Windows 10.  (Read 10841 times)

0 Members and 1 Guest are viewing this topic.

Offline streetwolf

  • Jr. Member
  • **
  • Join Date: Aug 2012
  • Posts: 99
  • Location: New Jersey, USA
  • Karma: 1
    • View Profile
Problem with Registry Backup v3.2.3 on Windows 10.
« on: October 06, 2015, 04:12:59 PM »
Just installed the update and now clicking on any of the tabs does nothing.  I always remain at the Backup Registry menu.
« Last Edit: October 07, 2015, 12:18:39 PM by streetwolf »
Intel Core i9-9900K@5.1GHz | Gigabyte Z390 AORUS MASTER | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 32GB RAM | EVGA GTX 1080 Ti FTW3 11GB | BenQ PD3200U 32" 4K LCD | 4-512GB Samsung 970 PRO M.2 | 2TB Samsung 860 EVO | 480GB  SanDisk USB Extreme900 | Windows 10 Pro | FIOS 1Gb

Offline front360

  • Newbie
  • *
  • Join Date: May 2013
  • Posts: 9
  • Location: United Stated
  • Karma: 0
    • View Profile
Re: Problem with Registry Backup v3.2.3
« Reply #1 on: October 06, 2015, 08:49:39 PM »
I'm glad I'm not the only one.  Same issue here, Win 10 x64.  I tried downloading portable from other servers, but they have the same issue.
« Last Edit: October 06, 2015, 09:19:32 PM by front360 »

Offline streetwolf

  • Jr. Member
  • **
  • Join Date: Aug 2012
  • Posts: 99
  • Location: New Jersey, USA
  • Karma: 1
    • View Profile
Re: Problem with Registry Backup v3.2.3
« Reply #2 on: October 07, 2015, 03:55:50 AM »
I just sent an email to Shane referencing this post.
Intel Core i9-9900K@5.1GHz | Gigabyte Z390 AORUS MASTER | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 32GB RAM | EVGA GTX 1080 Ti FTW3 11GB | BenQ PD3200U 32" 4K LCD | 4-512GB Samsung 970 PRO M.2 | 2TB Samsung 860 EVO | 480GB  SanDisk USB Extreme900 | Windows 10 Pro | FIOS 1Gb

Offline Samson

  • Hero Member
  • *****
  • Join Date: Nov 2011
  • Posts: 915
  • Location: London
  • Karma: 38
    • View Profile
Re: Problem with Registry Backup v3.2.3
« Reply #3 on: October 07, 2015, 04:06:41 AM »
Registry Backup v3.2.3 (Portable) Working fine with XP  :smiley:

Offline Tomas_Sweden

  • Sr. Member
  • ****
  • Join Date: Oct 2011
  • Posts: 260
  • Location: Falk√∂ping
  • Karma: 7
    • View Profile
Re: Problem with Registry Backup v3.2.3
« Reply #4 on: October 07, 2015, 04:53:15 AM »
Registry Backup v3.2.3 is working fine, both portable and normal (installer) version. I have win 7 64-bit!

Tomas
Dell Laptop XPS L501X Intel i5-560M(2.66GHz), Win 7 Home Prem(SP1) 64 Bit, 4 GB RAM. Samsung SSD 850 PRO 256 GB.

Offline streetwolf

  • Jr. Member
  • **
  • Join Date: Aug 2012
  • Posts: 99
  • Location: New Jersey, USA
  • Karma: 1
    • View Profile
Re: Problem with Registry Backup v3.2.3
« Reply #5 on: October 07, 2015, 04:58:59 AM »
Might be a Windows 10 issue.
Intel Core i9-9900K@5.1GHz | Gigabyte Z390 AORUS MASTER | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 32GB RAM | EVGA GTX 1080 Ti FTW3 11GB | BenQ PD3200U 32" 4K LCD | 4-512GB Samsung 970 PRO M.2 | 2TB Samsung 860 EVO | 480GB  SanDisk USB Extreme900 | Windows 10 Pro | FIOS 1Gb

Offline chris635

  • Sr. Member
  • ****
  • Join Date: Nov 2011
  • Posts: 442
  • Location: USA
  • Karma: 11
    • View Profile
Re: Problem with Registry Backup v3.2.3
« Reply #6 on: October 07, 2015, 10:22:08 AM »
I have the same problem as well...windows 10.
Physical Science Technician
Avid Motorcyclist

Have a nice day - Chris

Offline streetwolf

  • Jr. Member
  • **
  • Join Date: Aug 2012
  • Posts: 99
  • Location: New Jersey, USA
  • Karma: 1
    • View Profile
Re: Problem with Registry Backup v3.2.3
« Reply #7 on: October 07, 2015, 12:17:34 PM »
Haven't posted a problem here in a long time.  I remember Shane would always reply within hours if not minutes.  Is he out of town?
Intel Core i9-9900K@5.1GHz | Gigabyte Z390 AORUS MASTER | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 32GB RAM | EVGA GTX 1080 Ti FTW3 11GB | BenQ PD3200U 32" 4K LCD | 4-512GB Samsung 970 PRO M.2 | 2TB Samsung 860 EVO | 480GB  SanDisk USB Extreme900 | Windows 10 Pro | FIOS 1Gb

Offline Julian

  • "Professional Googler"
  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jun 2015
  • Posts: 1325
  • Location: USA, New Mexico
  • Karma: 38
    • View Profile
Re: Problem with Registry Backup v3.2.3 on Windows 10.
« Reply #8 on: October 08, 2015, 05:07:01 AM »
It looks like it is a issue on windows 10 shane is fixing this in 3.3 it should be released tommorrow i believe  :wink:
Julian

Offline streetwolf

  • Jr. Member
  • **
  • Join Date: Aug 2012
  • Posts: 99
  • Location: New Jersey, USA
  • Karma: 1
    • View Profile
Re: Problem with Registry Backup v3.2.3 on Windows 10.
« Reply #9 on: October 08, 2015, 05:16:57 AM »
It looks like it is a issue on windows 10 shane is fixing this in 3.3 it should be released tommorrow i believe  :wink:

Yeah he emailed 3.3 but it still had problems.  I mentioned those problems to him.
Intel Core i9-9900K@5.1GHz | Gigabyte Z390 AORUS MASTER | Corsair 1000W PSU | Corsair H115i CPU Cooler | Corsair 32GB RAM | EVGA GTX 1080 Ti FTW3 11GB | BenQ PD3200U 32" 4K LCD | 4-512GB Samsung 970 PRO M.2 | 2TB Samsung 860 EVO | 480GB  SanDisk USB Extreme900 | Windows 10 Pro | FIOS 1Gb

Offline chris635

  • Sr. Member
  • ****
  • Join Date: Nov 2011
  • Posts: 442
  • Location: USA
  • Karma: 11
    • View Profile
Re: Problem with Registry Backup v3.2.3 on Windows 10.
« Reply #10 on: October 08, 2015, 08:26:35 AM »
It's been a while since I've been here..life happens. I thought about emailing him as well, but it looks like he is on top of it. Thank for the reports guys.

Chris
Physical Science Technician
Avid Motorcyclist

Have a nice day - Chris

Offline chris635

  • Sr. Member
  • ****
  • Join Date: Nov 2011
  • Posts: 442
  • Location: USA
  • Karma: 11
    • View Profile
Re: Problem with Registry Backup v3.2.3 on Windows 10.
« Reply #11 on: October 08, 2015, 05:57:24 PM »
I can confirm that the new version works on my system....windows 10.

Chris
Physical Science Technician
Avid Motorcyclist

Have a nice day - Chris

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Problem with Registry Backup v3.2.3 on Windows 10.
« Reply #12 on: October 09, 2015, 12:28:13 AM »
Yeap v3.3.0 released today.

The tab control for some reason wasnt playing nice with windows 10, odd thing is it is the same tab control is in the windows repair and the tabs are working fine in windows 10. I was scratching my head on that one.

But I went ahead and spent about 10 hours writing the tab control over and getting it updated. You can now even mouse scroll the tabs when they are in focus.

So the first test of it worked but then streetwolf was the only user still having trouble. I found that his DPI was set at 125% where myself and everyone else who tested where at 100%

Well I traced that down to the math the tab control was using. It moves the controls off the window and moves them back based all on math multiplied by the tab number. Well it looks like I found another bug in windows 10 or a change on purpose where the left value of the control was unable to be set above a certain amount (Which isnt a problem in any older version of Windows). This caused the math to be off and so it didnt display correctly for him.

So I dumped the math trick (After all with it being multiplied by the tab number, if i had a lot of tabs then that math would get really big) and instead changed it to where the controls are now tagged with what tab they belong to and are all kept at the same left value off screen. So now no more math and no more hiccups.

And thanks to that, it made the control even faster because now it only touches the controls I tag instead of all of them. So thanks to streetwolfs system I was able to make the tab control even better.

I even moved the sub classing code out of the control and into the sub classing safe dll making the control even more stable.

So even though the old tab control works fine in Windows repair I will be replacing it with the new version in the next update as well. And with all these control updates I did over the last 3 weeks I will also be updating my other programs as well to the new controls.

Shane

Offline dartsmaster

  • Newbie
  • *
  • Join Date: Oct 2015
  • Posts: 1
  • Karma: 0
    • View Profile
Re: Problem with Registry Backup v3.2.3 on Windows 10.
« Reply #13 on: October 09, 2015, 12:44:29 AM »
odd thing is it is the same tab control is in the windows repair and the tabs are working fine in windows 10.

Thanks for this great free program, but Registry Backup in Windows Repair 3.6.0 isn't working for me (Windows 10 x64). :sad: Clicking on any of the tabs shows only the first tab (Backup Registry). DPI is set at 100%, and I didn't have this problem with earlier releases. I'll await the next release of Windows Repair.

Offline Shane

  • Lead Developer - Coder
  • Administrator
  • Hero Member
  • *****
  • Join Date: Sep 2011
  • Posts: 9279
  • Location: USA
  • Karma: 138
  • "Knowledge should be shared not hidden."
    • View Profile
    • Tweaking.com
Re: Problem with Registry Backup v3.2.3 on Windows 10.
« Reply #14 on: October 09, 2015, 01:01:05 AM »
Windows repair 3.6.0 still has RB 3.2.3 in it and I will be updating that on monday to the newest version. When RB opens from the windows repair look at the title bar and you will see the version and see that it isnt 3.3.0 :wink:

Shane