Author Topic: "Prevent" NTFS_FILE_SYSTEM 0x00000024  (Read 3667 times)

0 Members and 1 Guest are viewing this topic.

makinero

  • Guest
"Prevent" NTFS_FILE_SYSTEM 0x00000024
« on: July 05, 2016, 04:01:57 PM »
cause is depletion of nonpaged pool memory. If the nonpaged pool memory is completely depleted, this error can stop the system.
NTFS_FILE_SYSTEM 0x00000024

Protection of data against corruption in the case of virtual memory,
Assign the required virtual memory for the system, do not allow applications to use 100% pagefile.sys
How to set it up?

Please do not recommend me to increase the virtual memory on huge!
My Virtual Memory is optimal max. 16400 MB (16 GB), but some programs can use RAM FULL + FULL PAGEFILE.SYS (Processing of large data) and cause system crashes !!!







Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 9849
  • Location: UK
  • Karma: 121
    • View Profile
Re: "Prevent" NTFS_FILE_SYSTEM 0x00000024
« Reply #1 on: July 05, 2016, 04:31:49 PM »
It's amazing what Google can find - this is what MS suggest -

https://msdn.microsoft.com/en-us/library/windows/hardware/ff557433(v=vs.85).aspx
Tom.

makinero

  • Guest
Re: "Prevent" NTFS_FILE_SYSTEM 0x00000024
« Reply #2 on: July 05, 2016, 04:36:46 PM »
I know about this.
The forum should not exist, if you refer only to google:
I ask for something else, and you propose a very know solutions!!! :angry:

edit:
I want set config:

Example:
Maximum File Size pagefile to use Application: XXX MB . . . example 16GB pagefile  (usemax ~14 GB)
Maximum File Size pagefile tu use System OS: XXX MB . . . example 16GB pagefile (10%-15%*** ~1,6 GB - 2,4 GB)

***Recommended 10% -15%

This guarantees that no error exhaustion Paged Pool
« Last Edit: July 05, 2016, 04:52:40 PM by Ξ »

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 9849
  • Location: UK
  • Karma: 121
    • View Profile
Re: "Prevent" NTFS_FILE_SYSTEM 0x00000024
« Reply #3 on: July 06, 2016, 05:17:15 AM »
Even Shane will Google for an error message if he hasn't come across it and before I ask for help, I will search Google for answers.

As a rule of thumb, you set the Paging File to 1½x your actual RAM, but it's up to you if you want to set it higher.

I have 8GB RAM installed of which Windows sees that as 7787MB.

My Paging File shows as min. 16MB and recommended 11680MB. 
Tom.

makinero

  • Guest
Re: "Prevent" NTFS_FILE_SYSTEM 0x00000024
« Reply #4 on: July 06, 2016, 05:54:19 AM »
I set the 100 GB pagefile.sys but it does avoid the virtual memory is exhausted if all processes will use all the resources of the computer (!)
So this is a hopeless solution


Quote
16 MB ?
This is the wrong setting, does not register errors BSOD (dump) or other details of the error log.
The minimum should be: 800-1024 MB.

makinero

  • Guest
Re: "Prevent" NTFS_FILE_SYSTEM 0x00000024
« Reply #5 on: July 07, 2016, 02:50:18 AM »
Quote
As a rule of thumb, you set the Paging File to 1½x y

Program uses 100% RAM and 100% pagefile.sys (minimum 1024 MB . . .  maximum size: 20000 MB (+/- 20 GB))

So the operating system
Quote
Out of Memory
Quote
exhaustion of the pool of virtual memory
, I get a BSOD  0x00000024 and damages the NTFS File  :undecided:


« Last Edit: July 07, 2016, 02:54:22 AM by Ξ »