Author Topic: Crashing  (Read 1036 times)

0 Members and 1 Guest are viewing this topic.

Offline CollinChaffin

  • Newbie
  • *
  • Join Date: Oct 2017
  • Posts: 2
  • Karma: 0
    • View Profile
Crashing
« on: October 26, 2017, 03:42:56 AM »
No idea why the many posts all indicating crashing of these apps are all apparently locked (or at least the ones I need to add to).

Since these apps deal with the registry and hard crashes can completely destroy a working system, I'm surprised these support threads do not get a bit more attention.

Like the others that have opened threads in the last ~1-2 years, I too get hard crashes in both the registry compressor (not updated since 2014) and more importantly, now repeated user32 crashes on MULTIPLE Win7x64 systems with the latest 3.5.3 of registry backup.

I will return once I get back on a test system to add to my post one of the crash dumps, but I also get crashes in msvb runtime in the reg compressor after the actual compression and only after clicking the "apply" to slide the new reg file rename keys into place and reboot - so no idea why that hard crashes but I do see multiple other posts on exactly this kind of msvb runtime crashing in these 2 apps, so is this a known issue?  Is this being worked on or investigated?


Offline CollinChaffin

  • Newbie
  • *
  • Join Date: Oct 2017
  • Posts: 2
  • Karma: 0
    • View Profile
Re: Crashing
« Reply #1 on: October 26, 2017, 05:18:38 AM »
Well, I've been a dev myself almost 30 yrs so I just began debugging......looks like it's simply a friggin disk io parsing exception......once I have many regbackups it occurs.  Changing the target location via settings.ini to a temp folder with no existing reg backups results in the window now, instead of the ~30 friggin delay just opening before it even crashes (should have tipped me off), immediately opening and no errors.

Of note, a FRESH install is what first tipped me off because it ALWAYS opened once, and then also was fine after configuring with my options AND my existing target location, and in fact then allows a successful backup.  However, clearly the app is periodically refreshing itself (for the purposes of preseting the existing backups in the "restore" tab I'm presuming), because my last testing showed that after a successful 1st backup to my existing location, if I simply let the window then sit totally IDLE and don't touch it, and in fact leave it on the very 1st backup tab.....after a couple of minutes suddenly out of nowhere, the very same user32.dll crash.  Then of course, all bets are off because with the very well populated existing backup location now defined, the app will crash 100% and never even fully open for even a second until the existing backup location is removed.

Unfortunately, this is reproducible on ALL my systems (good handful) because as a good organized person I have pointed all of them to my central server's UNC (via mapped drive) to the same regbackup folder since this app automatically (and nicely IMO) creates a HOSTNAME subfolder in the regbackup target - but also means this bug once a regbackup target tree is large enough - will now crash not one but ALL the systems using this target storage.

I don't have the code obviously but let me know what (if anything) I can provide you for debugging.  I love this app and have actually had to use the backups before so hopefully it is something you can hunt down in the code!  TIA!

Offline jpm

  • Administrator
  • Full Member
  • *****
  • Join Date: Mar 2015
  • Posts: 160
  • Karma: 36
    • View Profile
    • Tweaking.com
Re: Crashing
« Reply #2 on: October 26, 2017, 02:02:47 PM »
What mode is the reg backup running? Basic or Shadow copy?

 

anything