Author Topic: Install problem resolution  (Read 337 times)

0 Members and 1 Guest are viewing this topic.

Offline jhvance

  • Newbie
  • *
  • Join Date: Apr 2017
  • Posts: 24
  • Karma: 0
    • View Profile
Install problem resolution
« on: June 12, 2019, 01:12:57 PM »
Some time back, I created a now-locked thread (https://www.tweaking.com/forums/index.php/topic,6083.0.html) with a temporary resolution for installing the Tweaking tool by booting into safe mode to accomplish that task successfully, but as the workaround wouldn't enable my Acronis TrueImage app to install in safe mode I had not completed a backup; that changed earlier today and the resolution may help someone else with comparable installation problems.

This started when I had become frustrated with the various "help" offerings through MS or most of the other sites which were identified in searches on the original error message, and life intervened in the form of chores and weather to distract me until this morning.  A new update for Skype today wouldn't install in a similar manner, but presented a different style and form of error message ("Access is denied" referencing "error 5")  -- another search with the combination brought up many of the same threads and posts as earlier, but also one reference to the MS KB article linked below, which revealed the problem lay somewhere in the permissions for vital folders being "read-only" as the installation process requires writing to such a folder.  The solution is to select the critical TEMP folders and toggle the top folder's properties "read-only" feature on and off, choosing the option to apply the action to all files and folders below; one may be under the root drive C:\ and the other under the relevant Windows\USERS\***\AppData\Local\Temp path.

https://support.microsoft.com/en-us/help/2623670/access-denied-or-other-errors-when-you-access-or-work-with-files-and-f

After I took that action for both folder lines and rebooted, I re-attempted the Skype update; it ran through fine, so I launched the TrueImage installation again and it ran through to completion.  Once I got the product activated and an initial backup performed, I went to their user forum to report the method of fixing the related installation errors and have now come here to report on the resolution.  I'll have to wait to test it against a new release of the Tweaking tool, and will report the outcome at that point in an update to this post if it remains unlocked.

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 8539
  • Location: UK
  • Karma: 115
    • View Profile
Re: Install problem resolution
« Reply #1 on: June 12, 2019, 01:35:00 PM »
I've unlocked your previous thread should you wish to add to it, but in it you said that 4.4.8 installed fine in normal mode.

Have you now installed 4.5.1 ?
Tom.

Offline jhvance

  • Newbie
  • *
  • Join Date: Apr 2017
  • Posts: 24
  • Karma: 0
    • View Profile
Re: Install problem resolution
« Reply #2 on: June 12, 2019, 01:59:45 PM »
Sorry, I wasn't complete in the description of how interim build installations actually went -- once I got 4.4.8 installed in safe mode and ran it, I tried the next update (4.4.9, I guess) in normal mode and it worked in normal mode, as did 4.5.0.  With 4.5.1 though, I discovered it had gone back to bad behavior and I relied on the workaround to get it installed.  I'll see what behavior occurs with the next release, as the fix described should have resolved it more permanently (at least until an MS update farkles it again).

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 8539
  • Location: UK
  • Karma: 115
    • View Profile
Re: Install problem resolution
« Reply #3 on: June 12, 2019, 02:04:17 PM »
I wonder why 4.5.1 wouldn't install in normal mode.
Tom.

Offline jhvance

  • Newbie
  • *
  • Join Date: Apr 2017
  • Posts: 24
  • Karma: 0
    • View Profile
Re: Install problem resolution
« Reply #4 on: June 12, 2019, 02:52:53 PM »
I wonder why 4.5.1 wouldn't install in normal mode.

I'm not certain, but I think since I had not resolved the basic problem underlying everything, I didn't give it the chance -- when I had downloaded the installer, I eventually rebooted into safe mode and did it that way.  I'll try to install in normal mode first with the next update, and I'll make an addition to the old thread which links to this one, and you can lock it again afterwards as closed.

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 8539
  • Location: UK
  • Karma: 115
    • View Profile
Re: Install problem resolution
« Reply #5 on: June 12, 2019, 03:01:03 PM »
Okay.
Tom.

Offline jhvance

  • Newbie
  • *
  • Join Date: Apr 2017
  • Posts: 24
  • Karma: 0
    • View Profile
Re: Install problem resolution
« Reply #6 on: June 14, 2019, 08:03:09 AM »
Well, there's progress of a sort -- on the W10H machine which originally had the install block that appeared to have been resolved, an error message appeared again when attempting to install v4.5.2 in normal mode.  While I rebooted that machine into safe mode w/networking, I installed the new tool without hiccups or issues on a different Win10H laptop which had never exhibited the install issue earlier; it did not arise now as the new software version installed properly in normal mode.  Once the other machine had finished booting into safe mode, the new version installed without problems on it as well.  I guess from now on, I'll just have to follow that protocol with installation of new Tweaking versions on the wonky machine as a less-PITA approach by comparison with wasting a lot more time trying to figure out why the install app doesn't like its normal OS mode.

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 8539
  • Location: UK
  • Karma: 115
    • View Profile
Re: Install problem resolution
« Reply #7 on: June 14, 2019, 08:44:00 AM »
What was the error message ?

You could perform a repair install on that machine which won't affect your personal stuff or installed programs and then see what it's like with the next update.

Does Event Viewer record anything for when you updated to 4.5.2 ?

I've added Take Ownership to my right click context menu where I can take ownership when I right click on the desktop icon but I don't know if that just gives me ownership of the icon.
Tom.

Offline jhvance

  • Newbie
  • *
  • Join Date: Apr 2017
  • Posts: 24
  • Karma: 0
    • View Profile
Re: Install problem resolution
« Reply #8 on: June 14, 2019, 11:09:18 AM »
There are 3 yellow-icon warnings in the event viewer application group, with this explanation: "Profile notification of event Load for component {B31118B2-1F49-48E5-B6F5-BC21CAEC56FB} failed, error code is See Tracelogging for error details."  Not particularly helpful, but the entry does point to SYSTEM as the user.

In the SYSTEM group, there are errors at a comparable (but not identical) time-stamp for "Event 10016, Distributed DCOM"  which provide this general description:

"The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}
 and APPID
{15C20B67-12E7-4BB6-92BB-7AFF07997402}
 to the user RIVENDELL2\James Vance SID (S-1-5-21-3774824159-2135294730-2250967024-1002) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

The detailed description for that same event in friendly mode provides this:

- System

  - Provider

   [ Name]  Microsoft-Windows-DistributedCOM
   [ Guid]  {1B562E86-B7AA-4131-BADC-B6F3A001407E}
   [ EventSourceName]  DCOM
 
  - EventID 10016

   [ Qualifiers]  0
 
   Version 0
 
   Level 2
 
   Task 0
 
   Opcode 0
 
   Keywords 0x8080000000000000
 
  - TimeCreated

   [ SystemTime]  2019-06-14T17:28:28.935986400Z
 
   EventRecordID 25718
 
   Correlation
 
  - Execution

   [ ProcessID]  1556
   [ ThreadID]  2432
 
   Channel System
 
   Computer Rivendell2
 
  - Security

   [ UserID]  S-1-5-21-3774824159-2135294730-2250967024-1002
 

- EventData

  param1 application-specific
  param2 Local
  param3 Activation
  param4 {2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}
  param5 {15C20B67-12E7-4BB6-92BB-7AFF07997402}
  param6 RIVENDELL2
  param7 James Vance
  param8 S-1-5-21-3774824159-2135294730-2250967024-1002
  param9 LocalHost (Using LRPC)
  param10 Unavailable
  param11 Unavailable

------------------------------------

Insofar as an installation log for v4.5.2, I can't find one -- it's occurred to me they may not be created when in safe mode, but don't know.  Under the setup group of logs, the last of those dates from Patch Tuesday a few days ago.

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 8539
  • Location: UK
  • Karma: 115
    • View Profile
Re: Install problem resolution
« Reply #9 on: June 14, 2019, 01:36:53 PM »
The DCOM Event ID 10016 is nothing to worry about.

I also got those after upgrading to Win 10 and followed the steps in this article to resolve but subsequent repair installs just brought them back and I've never noticed any adverse effects because of them.

This article is for Win 8 but the steps are the same for Win 10 if you want to bother with it - https://www.eightforums.com/threads/numerous-event-id-10016-errors-win-8-pro-64-bit.11951/

Have you run the repair program to see if it resolves the possible Permissions problem when updating WR in normal mode ?

I'd still go for a repair install to see if that resolves but as this takes 3 - 4hrs you may just want to put up with the inconvenience of having to boot into Safe Mode with Networking to do it.
Tom.

Offline jhvance

  • Newbie
  • *
  • Join Date: Apr 2017
  • Posts: 24
  • Karma: 0
    • View Profile
Re: Install problem resolution
« Reply #10 on: June 14, 2019, 01:47:55 PM »
Well, that link sure provides what seems like a complete and comprehensive checklist for a deep dive into the OS innards to effect (perhaps) a fix, so a bit more time than I've got at present and will set it aside for a later time by just performing a safe-mode reboot for future Tweaking installs as the lazy approach.  Thanks very much, regardless!

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 8539
  • Location: UK
  • Karma: 115
    • View Profile
Re: Install problem resolution
« Reply #11 on: June 14, 2019, 01:58:40 PM »
Read through the full article as some Event ID 10016 referred to different keys, but before you change anything in the registry it is always advisable to create a restore point.
Tom.