Author Topic: Problem with update 4.9  (Read 9093 times)

0 Members and 1 Guest are viewing this topic.

Offline jcarra8963

  • Newbie
  • *
  • Join Date: May 2019
  • Posts: 12
  • Karma: 0
    • View Profile
Problem with update 4.9
« on: May 14, 2019, 11:17:45 am »

Get a windows error message on update..C:\program files(x86)\Tweaking.com\windows repair (All-in-one)\repair_windows.exe                                   update finishes if I continue but does not open app

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: Problem with update 4.9
« Reply #1 on: May 14, 2019, 02:15:50 pm »
Try a fresh install from www.tweaking.com

You can install on top of the existing install without uninstalling first.

Offline jcarra8963

  • Newbie
  • *
  • Join Date: May 2019
  • Posts: 12
  • Karma: 0
    • View Profile
Re: Problem with update 4.9
« Reply #2 on: May 15, 2019, 08:50:22 am »
I did, same issue. Can't find repair_windows.exe

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: Problem with update 4.9
« Reply #3 on: May 15, 2019, 08:53:00 am »
Can you try the reinstall in Safe Mode with Networking and then see if it will open in that mode.
« Last Edit: May 15, 2019, 09:15:11 am by Boggin »

Offline jcarra8963

  • Newbie
  • *
  • Join Date: May 2019
  • Posts: 12
  • Karma: 0
    • View Profile
Re: Problem with update 4.9
« Reply #4 on: May 17, 2019, 08:49:49 am »
Did uninstall, reboot, and fresh install.  It opened up fine but I got a message that windows does not have enough permissions to run repair_windows.exe;  Even tried running as administrator, same message.  Any more suggestions?

Offline jcarra8963

  • Newbie
  • *
  • Join Date: May 2019
  • Posts: 12
  • Karma: 0
    • View Profile
Re: Problem with update 4.9
« Reply #5 on: May 17, 2019, 09:12:43 am »
Can you try the reinstall in Safe Mode with Networking and then see if it will open in that mode.

see message below

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: Problem with update 4.9
« Reply #6 on: May 17, 2019, 09:22:10 am »
That pic shows the machine to be in normal mode.

Can you right click on the desktop icon and select Properties.

Click on Compatibility and then on Run compatibility troubleshooter to see what that reports.

While I have it installed on two Win 10 machines and a Win 7 one, on this Win 10 machine it is running as for Win 8.

Sometimes changing the version can resolve this permissions problem.

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: Problem with update 4.9
« Reply #7 on: May 17, 2019, 09:34:17 am »
Just had another look at your pic - where is the icon for Windows Repair ?

Offline jcarra8963

  • Newbie
  • *
  • Join Date: May 2019
  • Posts: 12
  • Karma: 0
    • View Profile
Re: Problem with update 4.9
« Reply #8 on: May 17, 2019, 09:38:20 am »
Same issue.....running in windows 8 mode according to the compatibility app.

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: Problem with update 4.9
« Reply #9 on: May 17, 2019, 09:40:44 am »
Can you check the box and try different versions ?

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: Problem with update 4.9
« Reply #10 on: May 17, 2019, 09:49:35 am »
MS has a series of steps to troubleshoot this problem - https://support.microsoft.com/en-nz/help/2669244/windows-cannot-access-the-specified-device-path-or-file-error-when-you

If it's genuinely a Permissions problem then you can add this hack to give you a right click option to Take ownership.

https://www.tenforums.com/tutorials/3841-add-take-ownership-context-menu-windows-10-a.html

How are you accessing the program because I couldn't see its icon on your desktop.

Have you tried running the program in Safe Mode with Networking - this will isolate your antivirus and all other 3rd party programs.

Offline jcarra8963

  • Newbie
  • *
  • Join Date: May 2019
  • Posts: 12
  • Karma: 0
    • View Profile
Re: Problem with update 4.9
« Reply #11 on: May 17, 2019, 10:55:15 am »
funny thing.  After I get the permissions error message, the icon changes on the desktop and repair_windows.exe disappears.  Will uninstall and reboot into safe mode with networking to install again.  Did notice in windows C:users\jchppc\install of tweak with the executable repairs_windows in it even after uninstall.  Deleted all traces of Tweak on C:

Offline jcarra8963

  • Newbie
  • *
  • Join Date: May 2019
  • Posts: 12
  • Karma: 0
    • View Profile
Re: Problem with update 4.9
« Reply #12 on: May 17, 2019, 11:32:10 am »
Did install in safe mode.  After getting the message about permissions the executable disappeared.  The icon does show running in windows8 compatibility.  Next steps is to go to microsoft as suggested.

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: Problem with update 4.9
« Reply #13 on: May 17, 2019, 01:40:28 pm »
So are you getting similar problems when you run the program in Safe Mode with Networking ?

If you are, then that would eliminate AVG as the cause.

Offline jcarra8963

  • Newbie
  • *
  • Join Date: May 2019
  • Posts: 12
  • Karma: 0
    • View Profile
Re: Problem with update 4.9
« Reply #14 on: May 18, 2019, 08:48:14 am »
AVG?  I only use the driver update, not the virus and system maintenance part of AVG.  I have PCMatic as my virus and system maint software.  BTW, Microsoft didn't help.  Also, why is the icon executable and actual executable, Reapir_windows.exe, disappears after the error???????  When first installed, all is there in the folder but is gone after the message.

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: Problem with update 4.9
« Reply #15 on: May 18, 2019, 09:09:50 am »
That's why I thought it may be your antivirus program doing it, going by my previous experience with Norton Security and WR.

So are you getting similar problems in Safe Mode with Networking ?

Can you install that hack to put Take ownership into your right click context menu to take ownership when you right click on the icon before opening it and then see if you still get that error message.

I have that hack on all three of my laptops, so I know it's safe.

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: Problem with update 4.9
« Reply #16 on: May 19, 2019, 03:38:52 am »
I've just been having a read up on how PCMatic works. - https://www.pcmatic.com/supported

Can you contact them and ask if www.tweaking.com is on their whitelist ?


Offline jcarra8963

  • Newbie
  • *
  • Join Date: May 2019
  • Posts: 12
  • Karma: 0
    • View Profile
Re: Problem with update 4.9
« Reply #17 on: May 19, 2019, 10:14:46 am »
I checked the app on my pc for black and white lists and Tweak is not listed on either.  After install I did manage to do a scan, however, after the scan, the icon lost the Repair_windows.exe link and the executable got deleted again.  REALLY STRANGE!  Also, what do you mean by hack?

Offline jcarra8963

  • Newbie
  • *
  • Join Date: May 2019
  • Posts: 12
  • Karma: 0
    • View Profile
Re: Problem with update 4.9
« Reply #18 on: May 19, 2019, 12:20:01 pm »
My mystery missing executable link on the icon.  About to reach the point of going back to another version before 4.4.9

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: Problem with update 4.9
« Reply #19 on: May 19, 2019, 02:57:08 pm »
If you read this article you will see what I mean about the hack to add Take ownership to the right click context menu which is an easy way of taking ownership of a file/program.

https://www.tenforums.com/tutorials/3841-add-take-ownership-context-menu-windows-10-a.html

It sounds very much like PCMatic is the cause of this - this is why I was wanting you to install and run the repair program in Safe Mode with Networking to see what happens then.

In that mode all 3rd party programs are isolated from running which is why it is advocated running the repair program in that mode because an antivirus program can get in the way.

Antivirus programs depending upon their Definitions (usually) can become quite defensive when it comes to programs that have the ability to change the registry.

According to the article on how PCMatic works, a program is sent to PCMatic to check if it is white or black listed.

It would seem as the program is listed in neither, it is in limbo.

If the repair program opens and runs as it should in Safe Mode with Networking then I would advise you to contact PCMatic to have www.tweaking.com whitelisted and then see how things go.

At the bottom of the PCMatic article there is a Contact Us link you can use.

Offline jcarra8963

  • Newbie
  • *
  • Join Date: May 2019
  • Posts: 12
  • Karma: 0
    • View Profile
Re: Problem with update 4.9
« Reply #20 on: May 20, 2019, 09:46:49 am »
Thanks for your response but I did install it in safe mode and still had issues (check the comment string).  I'll check with PCmatic.

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: Problem with update 4.9
« Reply #21 on: May 20, 2019, 09:51:32 am »
It would seem that PCMatic is kicking it out in normal mode but I wouldn't have expected any antivirus related problems in Safe Mode.

However, see what happens after PCMatic whitelists it.

Offline jcarra8963

  • Newbie
  • *
  • Join Date: May 2019
  • Posts: 12
  • Karma: 0
    • View Profile
Re: Problem with update 4.9
« Reply #22 on: May 20, 2019, 10:14:48 am »
You are correct sir.  PCmatic is blocking it.  I logged into PCstop and found out it did block it a few times for my pc.  I have requested them to whitelist it.  I hope you are not Ransomware!!!!!

Offline Boggin

  • Global Moderator
  • Hero Member
  • *****
  • Join Date: Jul 2014
  • Posts: 10182
  • Location: UK
  • Karma: 122
    • View Profile
Re: Problem with update 4.9
« Reply #23 on: May 20, 2019, 02:33:03 pm »
WR is certainly not Ransomware :LOL

However, I hope you create regular system images onto external media as that is the only true defence against Ransomware.